Dumb question: Script editor selecting whole line?

On 08/11/2016 at 11:18, xxxxxxxx wrote:

Hey guys,

I use an external tool for writing stuff in, but of course I use the Expression Editor/Script Manager often, and I think I've accidentally hit a weird hotkey (though I've looked through all the Script Manager hotkeys and can't find anything that would cause this) or something that's made them behave unusually.  That is, every time I click on a line, it automatically selects the whole line instead of just moving the text cursor.

Has this happened to anyone/am I overlooking something really obvious, or is it just being weird?

Thanks :slightly_smiling_face:

On 09/11/2016 at 02:18, xxxxxxxx wrote:


I have never experienced something like this and also am not aware of any option to influence this.

Do you have this problem only in Script Manager? Or also in other places with scripting options (Python Xpresso node, Python Generator, Interaction tag,...)? I guess, you already tried restarting Cinema 4D?
Also the version of Cinema you are running and the system it is running on (Win/OSX, version), would be useful information, to track this down.

Finally I do not regard this as any development related but rather a user interface question. 
So, I suggest to gather the above information and directly approach our user support.

On 09/11/2016 at 09:51, xxxxxxxx wrote:

I did try a software restart--a system restart did the trick.  Sorry, I shoulda tried that before posting :blush:

Thanks, Andreas

On 13/11/2016 at 14:35, xxxxxxxx wrote:

Er, I probably shoulda shared my details, in case it helps in the future: R17.055 on Windows 7