Out of memory C4D dialog

On 29/09/2016 at 09:42, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R17 
Platform:   Windows  ;   
Language(s) :


When I render 1 frame using Team Render with my VideoPostData, I get a pop up C4D dialog indicating Out of Memory. More than 1 frames are rendered correctly.  
How can I detect that there are no frames to render in VideoPostData's Execute ?

Thank you.

On 30/09/2016 at 04:46, xxxxxxxx wrote:


hm, as a VideoPostData's Execute() is called from within the rendering pipeline, I don't think, you need to be able to detect this, the Execute() simply shouldn't be called, when there's nothing to render.

I think, we should first find out where the "Out of Memory" error is coming from. Did you try to run a Team Render Client in your debugger, so you could get a stack trace in the event of the error popup? Can you provide us with some details on your plugins code in that situation?

On 03/10/2016 at 00:12, xxxxxxxx wrote:


This issue appears only when I run "Team Render To Picture Viewer".
I don't have any Team Render Client started, but I have enabled Team Render in the team render preferences.

I have set to render only the current frame.
So when i start the rendering, I get the Out of memory window and "Preparing the rendering failed".
The Execute method in my VideoPostData doesn't run (not even the AllocateBuffers method).

When I run the same case using the standard Cinema4D render engine, the current frame is rendered fine.

What can I do to avoid this error and render the current frame without Team Render (even if it's enabled)?

Thank you.

On 04/10/2016 at 01:29, xxxxxxxx wrote:

To give some more information:
I define the video post plugin using 

And in GetRenderInfo I always return VIDEOPOSTINFO_0.

On network rendering, I want each team render client to render a different frame and return it to server application.

Edit: I don't use any of NetFrameInit, NetFrameFree or NetFrameMessage.

On 04/10/2016 at 07:20, xxxxxxxx wrote:

I'd rather start with finding out, where the "Out of Memory" error gets thrown, instead of guessing, what might cause it. Did you run whatever instance of C4D throws the memory error in a debugger by now? Please do so, so I can get an idea of what is happening.

On 04/10/2016 at 07:30, xxxxxxxx wrote:


I run the plugin in debug mode and the running application is Cinema4D (Not Team Render Client).
On error thrown, i pause Visual Studio.

Here is the call stack:

> ntdll.dll!00007fff5df00c6a() Unknown
KernelBase.dll!00007fff5b2e13ed() Unknown
user32.dll!00007fff5c1132a4() Unknown
CINEMA 4D.exe!00007ff6ba65aa77() Unknown
CINEMA 4D.exe!00007ff6ba65155a() Unknown
CINEMA 4D.exe!00007ff6ba651965() Unknown
CINEMA 4D.exe!00007ff6ba992208() Unknown
kernel32.dll!00007fff5bdc13d2() Unknown
ntdll.dll!00007fff5de854e4() Unknown

Execute method in VideoPostData doesn't run.

Thank you for your time.

On 05/10/2016 at 11:24, xxxxxxxx wrote:

Ok, this won't lead anywhere (I was hoping for another thread), sorry for wasting your time.
Unfortunately our render expert (Sebastian) is currently on vacation and I can only slowly work myself into all the details.

I see two options for progress:

a) Are you aware of this thread? It contains an example of a VideoPostData renderer supporting TR. The example works fine here with single frame team rendering to Picture Viewer. So maybe you can find some useful hints in there.

b) Could you provide me with some simplified code, that shows the issue, so I could do some tests here?