Melange renderconnection



  • On 09/09/2016 at 08:05, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:    
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    There is a problem with the renderconnection example in Melange.
    On my laptop running Win7+SP1. And built in graphics. The application does not render a .c4d file properly. And the rendered value never reaches 100% or "finished".
    But If I minimize the application. Then maximize it again. The render does show up fully rendered in the app's window.

    I have not tried it on another computer yet.
    But I'm guessing that the code used is not doing an aggressive enough draw operation for people with low end graphics. So developers should be aware that using that code as a base might not work properly on all computers.

    -ScottA

    Edit-
    One other thing that I stumbled on by accident.
    The .c4d file I was using to test the app was set to render current frame.
    After setting it to render all frames. And I animated the object in the scene with key frames. If I run the app, then minimize it--->then maximize it. The rendering seems to work properly. And the render value text also works properly.
    There are 3 threads in the example. And each one seems to work properly.
    But only if I do that minimize/maximize the app thing at the beginning.



  • On 12/09/2016 at 09:21, xxxxxxxx wrote:

    I'm looking into it.



  • On 12/09/2016 at 09:30, xxxxxxxx wrote:

    I tried it on a different computer today with a better graphics card. And it works much better.
    Not really a bug I guess. More of a system requirement issue.
    Just thought I'd give you guys a heads up about it.

    -ScottA



  • On 12/09/2016 at 09:32, xxxxxxxx wrote:

    I don't think, this has anything to do with the graphics card. I rather suspect some kind of race condition leading to a missing window update.



  • On 13/09/2016 at 11:42, xxxxxxxx wrote:

    I got feedback from development.
    There's indeed a refresh missing. It is a known issue, but it's considered low priority as it's on the Windows side, which is not really the focus of the example.


Log in to reply