Generator Object and Physical Renderer



  • On 30/05/2016 at 07:33, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R16+ 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    In my latest commercial plugin there is a strange and very difficult issue to resolve.  The plugin is a ObjectData plugin used as a direct generator (no children) of polygon objects.  In every renderer, it works except in the Physical renderer in the Editor View.  Works in the Picture Viewer render using Physical!

    I've tried SetUniqueIP() with OBJECT_UNIQUEENUMERATION.  I've played around with render settings, project settings, object settings, code.  It refuses to render the Editor view if Physical renderer is set.  And I know that this is a known 'issue' with the Physical renderer (say, for MoText?).

    Is there anything that can resolve this in code?

    Thanks,



  • On 30/05/2016 at 07:50, xxxxxxxx wrote:

    Update:

    Once I worked out setting all of the underlying object IP's properly, the Physical renderer decided that it liked everything.  Mark as resolved.



  • On 31/05/2016 at 02:57, xxxxxxxx wrote:

    Hi Robert,

    glad you solved your issue.
    You mentioned a known issue with MoGraph generators and the physical renderer. Can you elaborate on this, so I can check?



  • On 31/05/2016 at 05:20, xxxxxxxx wrote:

    While researching the basic parameters of the problem on my end, I found some interesting issues on forums discussing the Physical render (e.g.) :

    https://forums.creativecow.net/thread/19/883869

    http://www.c4dcafe.com/ipb/forums/topic/81478-physical-render-and-inheritance-bug/

    These are from older versions of C4D and I don't have more of a list at hand.  It simply assisted me since MoGraph was involved and I'm using a dynamic generator in similar ways.  This led to looking here and thinking that maybe Physical render is requiring UniqueIP's for my objects even if I'm not using them in my code for anything.


Log in to reply