ObjectPlugin - Attributes



  • On 30/03/2016 at 13:24, xxxxxxxx wrote:

    Hey guys,

    so I am working on a Object Plugin for particles.
    My problem is (and I had this problem in some other plugins before) that as soon as I "create" a second attribute for my Object like in the picture below the Bitmapbutton, I always get this error message:
    AttributeError: 'module' object has no attribute 'dev_header'
    and I don't know how to get rid of it, since I already have an attribute (which is functioning) in my object.

    Picture: http://prntscr.com/am6b95

    I really don't know how to solve this problem, 
    I hope someone can help me out with that.

    Thanks in advance,
    neon



  • On 31/03/2016 at 08:23, xxxxxxxx wrote:

    Hi neon,

    there seems to be an issue with the symbol cache.
    Please try the following:
    Go to your user's Cinema 4D home directory (a quick way from within Cinema: open the preferences and click the "Open Preferences Folder..." button in the lower left). In there you will find a "prefs" folder. In this prefs folder you'll find a file called "symbolcache". Delete this file and start Cinema. The symbol cache will be rebuilt and your problem is hopefully solved.



  • On 31/03/2016 at 09:06, xxxxxxxx wrote:

    Hello Andreas,

    Thanks for your help, it worked! 
    I really had this problem for quite a while now, and I always thought I messed something up in my code.

    Just one litle question: is there some way I can prevent this error happening?

    greetings,
    neon


Log in to reply