Plugin does not load [SOLVED]



  • On 09/02/2016 at 11:54, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R17.029 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    I guess this is asked before, but I cannot find any posts with answers.

    I have a very simple c++ plugin compiled with VS Express 2012 sp5.
    It runs fine on my windows 8.1 with cinema 4d R17.029

    One of my customers complains that the plugin is not loaded on his machine.
    A (new) Windows 10 machine running R17.016.

    What could be wrong?
    Perhaps a missing dll?

    - Pim



  • On 09/02/2016 at 12:08, xxxxxxxx wrote:

    I'm not a 100% sure if that is also the case for the minor version number, but Cinema will refuse to
    load a plugin that was compiled with an older SDK. (in this case 17.016 < (older) 17.029)



  • On 09/02/2016 at 12:39, xxxxxxxx wrote:

    Agree with Niklas.  Minor updates to Cinema 4D are FREE so it is up to the customer to have the latest version.  If Cinema 4D doesn't do it by itself, the user can simply check (Help->Check for Updates...")



  • On 09/02/2016 at 13:09, xxxxxxxx wrote:

    Great, I will ask the user to upgrade and report back.

    Thanks, Pim



  • On 10/02/2016 at 02:21, xxxxxxxx wrote:

    Hello,

    the API version (defined in the API_VERSION macro) of release 17.016 is 17000 , while the version of 17.032 is 17030. A plugin build with a higher version won't load in a Cinema 4D installation that is using a lower version.

    Best wishes,
    Sebastian



  • On 11/02/2016 at 01:04, xxxxxxxx wrote:

    Thanks for all the help and information.
    It is solved now!

    -Pim


Log in to reply