C4D missing plugins



  • On 16/11/2015 at 05:29, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R17 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hello.

    When i start a specific project (which is sent to me by another user), i get notified for some of its missing plugins that the other user has installed in its C4D and i don't.
    Can i somehow get the ids of these plugins (code-based)?

    Thank you for your time.



  • On 16/11/2015 at 05:55, xxxxxxxx wrote:

    I'm not sure you can reverse find plugin with ID.



  • On 16/11/2015 at 08:04, xxxxxxxx wrote:

    Sure you can. C4DAtom->GetType() returns the plugin ID of the atom.  The problem is if you can do so when the plugin isn't present.  I'd have to test this but am in the middle of a backup so it may not be until later.



  • On 16/11/2015 at 08:37, xxxxxxxx wrote:

    One thing to note is that the message displayed by C4D includes the plugin ID of the missing plugin as well as the plugin's 'name'.  It must be stated that the IDs could be for a group of plugins within a single plugin (could be object and tag plugins used by the same 'plugin').

    The question then becomes: what are you trying to achieve if you don't have the plugins used by the user's project?



  • On 16/11/2015 at 10:18, xxxxxxxx wrote:

    Hello.

    I have created a MaterialData which uses shaders. It parses them and handles them depending on their type (Xcolor, Xbitmap etc).
    The problem is that a user might try to put a shader from a plugin that i have not installed in my system.
    I have to handle this case as well.

    When using getType() for the fault shader, i get 5707 which is xbase. It seems that i cannot receive the missing plugin's true ID.

    Thank you.



  • On 17/11/2015 at 08:40, xxxxxxxx wrote:

    Hi,

    unfortunately, I see no option to get the ID of missing plugins, either.



  • On 17/11/2015 at 23:39, xxxxxxxx wrote:

    It's ok.

    Thank you for your time !


Log in to reply