Multiples questions [SOLVED]



  • On 27/10/2015 at 04:43, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   17 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hello,

    First message here and multiples questions mean multipes problemes !
    I'm new in developping in C++ but i' know a bit how dev in C++.

    I'm on Cinema 4D R17 and Visual Studio Express For Windows Desktop 2013

    1. I absolute can not understand why Cinema 4D insult me at every debug load with this message :

    It's a bit tiring to close this dialog box (by clicking continue) 2 or 3 times by debug session. But nothing serious.

    2 ) I can't find simple and easy to understand information about res files. Some time in the documentation ";" appear at the end of exemples and some times no. Should I use BOOL or CHECKBOX ? Do i have to place CHILDS of COMBOBOX in .h ? Probably in str ! How can i write comment in my res file ? Some times res files start with container but some time start with DIALOG ?

    For every of this question i can't find information and the SDK documentation is a bit... light on this. For thoses like me are starting in C++ (and python dialog) it could be hard to start. I can make the resEdit compil for VS 2013 and start on R17 (don't ask me how) but it's seems not working properly.

    thanks you in advance for any answel.
    Good day.



  • On 27/10/2015 at 06:58, xxxxxxxx wrote:

    For Exemple I can not understand why this return me a error :

    I tried to open Gediaolg_gadgets.cpp in cinema4dsdk exemple but all in this exemple is generated in the cpp code. And this is not recommended for translating.

    Could some one help me ? 3 day on this simple probleme make me feel realy creep.

    Thanks



  • On 27/10/2015 at 08:19, xxxxxxxx wrote:

    Additional informations.

    This work as expected:

    But this not...

    Additional question : In witch case i have to add semicolon after bracelets ?

    Many thanks in advance :-)



  • On 27/10/2015 at 10:47, xxxxxxxx wrote:

    Your resource files are throwing errors because you are using dialog elements in a description. COLORFIELD is for dialogs but for descriptions it is COLOR.

    As for why there is a difference, who knows, but there you are.

    Steve



  • On 28/10/2015 at 02:42, xxxxxxxx wrote:

    Thanks for your answer. I found the difference yesterday.
    Because some time i read in documentation BOOL and CHECKBOX.



  • On 28/10/2015 at 02:44, xxxxxxxx wrote:

    Did you know why this difference ? Some one for Tag and object and some others for real windows ?

    Thanks in advance.

    And maybe you have a idea for my first problem with debuger ?

    ;-)



  • On 28/10/2015 at 05:30, xxxxxxxx wrote:

    It's not specific to tags or objects. It's the difference between a dialog resource, used in dialog windows, and a description resource, which is used in the attributes manager. As to why the difference? Probably no-one, even at Maxon, could answer that, it'll be some historical reason lost in time. If they were starting from scratch now I don't suppose they'd do it that way but there you go. For compatibility reasons it won't ever change, you'll just have to learn both types of resource.

    Sorry, can't help with the debugger as I don't use that version of VS.



  • On 28/10/2015 at 05:37, xxxxxxxx wrote:

    Ok, thanks for your fast reply ! And many thanks to answer to my question !



  • On 28/10/2015 at 10:56, xxxxxxxx wrote:

    Hi,

    welcome to the Plugin Café forums 🙂

    Sorry, for chiming in so late.

    For dialog and description resources, Steve's absolutely right. I just want to add some links, which may shed some more light (even if you have found some of the infos already) :
    From the C++ SDK docs:
    Description Resource
    Dialog Resource
    Dialog Layout

    And before anybody asks, we are aware, that the documentation on this topic can be improved. We are working on it, but need to beg for your patience.

    I also don't know the reasons for the differences in the resource file syntax, but it is important to understand the differences between descriptions and dialogs.

    For a dialog you simply describe the layout of the user interface elements (widgets) and your dialog class (derived from GeDialog) simply reacts on events caused by the user input to these widgets.

    A description on the other hand, actually does not describe the GUI (at least not primarily), but instead it describes the parameters of an entity derived from NodeData (such as objects, materials, shaders, tags...). Cinema 4D will then take this description and will display appropriate widgets (this can be configured to a certain extend in the resource file of a description) for these parameters (for example in the Attribute Manager). Cinema 4D also takes care of storing the parameter values in the node's BaseContainer, when the user interacts with one of the parameter widgets. Your plugin's code won't react on user interface events, but instead you can react to parameter changes (SetDParameter()/GetDParameter()).

    Ok, and now for your debugger problem:
    Usually Cinema 4D doesn't do this. At least I did not experience it, yet, nor did I hear about this.
    Can you do me a favor and test, if this also happens with a clean installation of C4D?
    You could simply make a backup of the plugins folder and then remove everything but the SDK example project (cinema4dsdk, assuming you didn't modify it) for this test. Please let me know, if the breakpoint is still triggered on startup.



  • On 28/10/2015 at 11:23, xxxxxxxx wrote:

    Hi Andrea,

    First thing, thank you too for your long and interesting reply. Some time I'm a bit angry about things I can't do until solution is just in front of me. Sorry about my message.

    I'll will try a fresh and clean install tomorrow. I finally did my (very very simple) plug-in. Now time for optimization. And maybe you'll can help me ;-)

    See you tomorrow !



  • On 28/10/2015 at 11:27, xxxxxxxx wrote:

    Just before you have more work than I asked for. There's no need to re-install C4D. It's enough to make a backup of the plugins folder and remove everything except cinema4dsdk. You can move everything else back in after the test.



  • On 29/10/2015 at 02:28, xxxxxxxx wrote:

    Hi, so :

    I clear everything in my both plugin folders.
    screen-shot of console without debugger.

    I'm not sure if i have modified my cinema4dsdk. So i re-downloaded and rebuild it. Some modifications to my cinema4dsdk :

    With this configuration with only cinema4dsdk compiled i have no bug from my debuger. No dialog asking me to continue.

    When i copy back my own in the plugin folder... nothing more ... Good news. (but I'm still start debugging from cinem4dsdk)

    AutoRename: ok, C4DtoA :ok... Bref everything look good. Maybe a double copy of cinema4dsdk in software plugins folder and user folder...

    And everything looks good too when I start debugging from my own plugin !! Great

    Thanks for the reply both of you and see you around. You can mark this thread as solved.


Log in to reply