Move Tool not working [SOLVED]



  • On 08/09/2015 at 03:53, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R16 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hi,

    Are there any known problems with the move tool not working??

    I was adding some XPresso to my plugin, when suddenly I couldn't move many of my objects anymore.
    I'm 100% sure my XPresso files doesn't set the position of the objects I can't move anymore.
    The only way to move them is in the coördinates tab in the attributes manager. It is not working with the move tool or within the coördinates manager.

    Did somebody have the same issue?

    Thanks in advance for your help and time!



  • On 08/09/2015 at 04:08, xxxxxxxx wrote:

    I have the same problem with the rotation and scale tool.

    It seems like there is a problem with the matrix.

    If I use another plugin which sets the matrix (locally or globally), it works fine (the same as in the attributes manager).



  • On 08/09/2015 at 05:18, xxxxxxxx wrote:

    Also,

    If I try to move an object that was able to move together with an object that wasn't able to move, they are both not able to move...

    Could this be something with the modeling axis?



  • On 08/09/2015 at 05:57, xxxxxxxx wrote:

    Hi,

    Well, I've found my problem, and it was mindblowing.

    In one of the connections I did in Xpresso I put in the wrong node for a port.
    This apparentally causes some objects to not be moveable with the move tool or the coordinates manager.

    I'm glad my problem is solved, but I'd like an explanation on this, if possible.



  • On 08/09/2015 at 06:01, xxxxxxxx wrote:

    Also,

    What I had, was literally a half connection. It simply stopped halfway, since I gave the wrong port/node.


Log in to reply