XCode / R16



  • On 08/07/2015 at 04:05, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   16 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hi,

    I tried building the R16 cinema4dsdk using XCode 4.6 on OS X 10.7.5 and it seems to work, although the SDK states XCode 4.6.2 and OSX 10.8.5 as the minimum requirement.

    My question is, whether I can build compatible plugins with my configuration. I'm not a Mac user, I use a quite old MacBook that cannot be updated to a newer OS version.

    Thanks for any information.



  • On 08/07/2015 at 05:23, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    <ADDRESS>
    User Information:
    Cinema 4D Version:   16 
    Platform:   Windows  ;  
    Mac OSX  ; 
    Language(s) :    
    C++  ;

    ---------
    </ADDRESS> Hi,

    I tried building the R16 cinema4dsdk using XCode 4.6 on OS X 10.7.5 and it seems to work, although the SDK states XCode 4.6.2 and OSX 10.8.5 as the minimum requirement.

    My question is, whether I can build compatible plugins with my configuration. I'm not a Mac user, I use a quite old MacBook that cannot be updated to a newer OS version.

    Thanks for any information.

    Xcode 4.6 contains a slightly older clang c++ compiler (a few sub-versions) while 4.6.2 contains some compiler fixes. You might be fine with 4.6 on OS X 10.7.5, but this configuration isn't tested... therefore you're on your own.

    Best regards,

    Wilfried


Log in to reply