What version of Xcode? [SOLVED]

On 05/05/2015 at 12:39, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R16 
Platform:      Mac OSX  ; 
Language(s) :

---------
Howdy,

OK, I finally upgraded my Mac OS to Mavericks, so now what version of Xcode should I get to compile R16 plugins?

Adios,
Cactus Dan

On 05/05/2015 at 13:39, xxxxxxxx wrote:

Hello,

R16 requires XCode 5 or higher.

best wishes,
Sebastian

On 06/05/2015 at 05:22, xxxxxxxx wrote:

Hello,

I am using Xcode 6.3 for R16 .

Remo

On 06/05/2015 at 05:41, xxxxxxxx wrote:

Howdy,

Thanks. 😉

Adios,
Cactus Dan

On 06/07/2015 at 03:36, xxxxxxxx wrote:

The SDK docs says:
Development Environment Requirements
•Minimum OS requirement are Windows 7 (or newer) and OS X 10.8.5 (or newer).
•On Windows, Microsoft Visual Studio 2012 (or newer) is required.
•On OS X, XCode 4.6.2 (or newer) is required.

I tried building the cinema4dsdk using xcode 4.6 on OS X 10.7.5 and it seems to work. It's an old MacBook that cannot be updated to later OS X versions. So my question is, can I still delay awhile buying a new Mac or are there problems to be expected if I put those plugins on the market?