PNoise Problem



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 02/12/2002 at 16:04, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.012 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    When I use the PNoise function from the SDK (the time independant one) it always returns 1.

        
        
        PNoise(Vector(Noise(p)),p);
    

    bug or user error? :
    The time dependant one seems to work though.
    Samir



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 02/12/2002 at 21:43, xxxxxxxx wrote:

    The definition of PNoise within the v7 C4D SDK is
    Vector A = Evaluation Position    Vector B = Component Periods
    PNoise( A, B );
    Also take into consideration that Period Noise within the C4D SDK ( last time I asked ) does nothing more than scale the evaluation vector making the period lock at the loss of temporal control. In v7 MAXON said the table had 1024 entries. Render your own conclusion. :-)
    darf - bhodiNUT



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/12/2002 at 07:20, xxxxxxxx wrote:

    Hi,
    thanks Darf. The R8 doc description for PNoise is wrong in this case. It says the evaluation vector is the second variable passed to the function.
    It works just fine now.

    Also take into consideration that Period Noise within the C4D SDK ( last time I asked ) does nothing more than scale the evaluation vector making the period lock at the loss of temporal control.

    thanks for definition (and the docs still talk of 1024 entries :).
    Best
    Samir


Log in to reply