R15 example Effests not available

On 18/03/2015 at 22:36, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R15 
Platform:    Mac  ;  Mac OSX  ; 
Language(s) :     C++  ;


I'm having some problem with effect (video post) plugins on R15.
I compile the examples, lots of C++ options appear on the Plugins menu.
But none in the Render Settings Effects... :/
I already re-installed, updated and nothing.
Any ideas why only the effects should not be available?

On 19/03/2015 at 05:49, xxxxxxxx wrote:

Render menu-> Edit Render Settings... -> right click on the left "or click Effect... button"

On 19/03/2015 at 06:58, xxxxxxxx wrote:

That's where the problem is, the effects are not there...

On 19/03/2015 at 07:39, xxxxxxxx wrote:


on your screenshot it looks like that not only the video post effects are missing but that half of the SDK examples are not loaded.

When you open the main.cpp file you find the PluginStart() function. In this function all SDK example classes are registered. When a register process fails the functions is left so the remaining examples are not registered. So I guess that one of the register functions fails. You can set a breakpoint in the PluginStart() function and debug it to see which one fails. You find information on how to debug plugins on the developer blog.

Best wishes,

On 27/03/2015 at 08:09, xxxxxxxx wrote:


was your question answered or you problem solved?

Best wishes,

On 27/03/2015 at 12:41, xxxxxxxx wrote:

Hi Sebastian,

Yes, the debug was very helpful, I didn't know about it!
So I commented out some plugins and now I see the effects.
But I just have no idea why those plugins are not registering.

The bigger problem is that I was actually having the same with my plugin, the sdk was just to test why it happened with some reliable code.

My plugin was made with R13 and worked until R15.
So I ported it to R16, and made it compatible with R13 with some defines and typedefs (below).
And now the R13 version won't work on R15, it crashes all the time.
So I compiled it with R15 sdk using the new R16 syntax and with some modifications it now works for me.
But there's one user who says his new R15 version is crashing, but if he uses the R13 version, it will work.
This R15 instability is getting really annoying.

Here's what I added to the R13 version to make it compatible with R16:

#pragma once
//#if (defined C4DR13) || (defined C4DR15)
#if (defined C4DR13)
#ifndef C4DR13
#define C4DR13
// R13/14/15 compatibility to R16
typedef Real Float;
typedef SReal Float32;
typedef LONG Int32;
typedef LMatrix Matrix;
typedef UWORD UInt16;
#define SetFloat SetReal
#define GetFloat GetReal
#define SetInt32 SetLong
#define GetInt32 GetLong
#define PI pi
#define PI2 pi2
#define PI05 pi05
#endif	// C4DR13

On 30/03/2015 at 04:49, xxxxxxxx wrote:


if you could tell us which plugins fails to register we might be able to help you on that. If you want to discuss a crash that is not related to this thread's topic please open a new thread. Thanks.

Best wishes,

On 30/03/2015 at 07:57, xxxxxxxx wrote:

Also, to keep plugins compatible with different API versions one can set the preprocessor define __LEGACY_API. You find some information on that in the transition guide in the R15 documentation.

Best wishes,