Resedit crashes Cinema R16 [CLOSED]

On 07/01/2015 at 03:08, xxxxxxxx wrote:

User Information:
ResEdit Version:   R8

Hi all,

I did a pugin in R15 with a Non-Modal-Dialog.
Everything was fine.

Now i opened the .res file in R16.
Bue no names of the buttons are shown anymore.
Neither in the properties-Window, nor in the preview.

If I try to open language, C4D is dead.

Is there a new version avalible for R16 or what can i do to solve the problem?

Thanks a lot

On 07/01/2015 at 08:30, xxxxxxxx wrote:

Hi Kissling,

I recently tried the latest version of ResEdit in R16 to create a 'crash course' in its use, and it worked fine.  I know you asked for access to download ResEdit in a separate thread, so once you can, it should be the same version that worked for me.

The link to the crash course I wrote, including how to install it:

ResEdit Crash Course

I'd like to add that I've been told ResEdit does not replace using a text editor, as it only helps with some aspects of creating UI resources.  If any functionality seems dead, you'll simply have to continue editing your files in a text editor.

Joey Gaspe
SDK Support Engineer

On 09/01/2015 at 08:58, xxxxxxxx wrote:

Hi Kissling,

I can confirm what you're reporting with your res files, the labels are empty and when I opened the string table dialog, Cinema 4D R16 froze on my system.

Unfortunately, ResEdit has not been updated in a while, and I happen to only work with it briefly to create the crash course, so it details the limits of what I knew at the time.  It appears that if there's no string data in the file, it won't freeze, so that's why I didn't know that functionality was dead and went as far as freezing up C4D.  We also do not yet know if ResEdit is to be updated to work with R16 or not.

Therefore, if ResEdit works properly in R15, you may have to keep that version to use it.  Otherwise, as stated, you'll have to use a text editor.

Joey Gaspe
SDK Support Engineer

On 12/01/2015 at 00:24, xxxxxxxx wrote:


thanks for your responce.
Wohant do you mean with:
"It appears that if there's no "string data in the file???
In witch file?
And what string data?
Could you please send an example?

I know, for those guys like you whitch are programming all the day long, it´s easy to wright the .res and .str fliles.
But for a scrub lke me it is a verry helpful tool.


On 12/01/2015 at 12:40, xxxxxxxx wrote:

Hi Kissling,

I meant that when I wrote the crash course, I was creating my own data files, and so since the string tables start off empty and don't actually save to a file, there was nothing for it to load.  Your data files prove that if you create string table files with ResEdit in C4D R15 or with a text editor, and then load them with the current version of ResEdit in C4D R16, the loading code is also defective, to the point of freezing up C4D.

So, we would have to fix the string table saving and loading code in ResEdit to get it to work in C4D R16.


Joey Gaspe
SDK Support Engineer