HELP!!! Xcode not working [SOLVED]

On 02/03/2015 at 13:03, xxxxxxxx wrote:

Can anyone, at least tell me where should reside the file that is not being able to be created?

On 02/03/2015 at 14:37, xxxxxxxx wrote:

Hi Rui,

I only have limited Mac experience, but tried to find the file you mention that has the permission denied error.  I realized that it doesn't exist in the R16 SDK, the equivalent files were renamed from R15 SDK.  Besides that, I compiled the R16 SDK from the installed version of C4D for the first time, and didn't have any issues whatsoever, using XCode 6, which is the only version I have installed.

However, I can share with you some bits of knowledge I gained in the attempt.  To find the file, you'll have to either use the finder from the root of your hard disk, or if you are familiar with Terminal, go to the root of your hard disk in it and use the following command:

find . -iname lib_api_debug.a

If the file does exist, it will definitely find it if you search from the root and it's not in a totally blocked directory.  You'll then know what directory structure to delete to get rid of the 'permission denied' issue, as it looks like an older copy of the file or the directory it's stored in is set to read only, thus not allowing the new one you're trying to build to overwrite it.

As for all the warnings you're getting ('Semantic Issue', etc.), it looks like you're trying to compile a version of the SDK with a compiler version that is newer than intended.  However, I'm only guessing with the limited info.

Let us know how it goes, I'll watch this thread.

Joey Gaspe
SDK Support Engineer

On 03/03/2015 at 01:59, xxxxxxxx wrote:

I tried to revert back to Xcode 4.6.3 and now it doesn't even start.
I mean, it starts and then quits 😞

On 03/03/2015 at 08:33, xxxxxxxx wrote:

Hi Rui,

Sorry to hear you're in a worse position, but it seems like something is really messed up on your computer with Apple's XCode.  To some extent, computer platforms share common issues, and when things get really messed up, there's one general response (start over from scratch) :

1. Backup all your code and data, just to be safe.

2. You have to uninstall all your versions of XCode, probably from newest to oldest version.

3. Here's the crucial step: Delete all left over compiler configuration files, directories, etc. I have no idea how to do this, you'll have to look it up in Apple's forums or Mac OS X help sites.

4. Re-install the XCode versions you absolutely need in the recommended order from oldest to newest, carefully following the instructions you've certainly heard about to avoid any side by side issues.

5. Try compiling your projects again, making sure nothing is left to being discovered broken in the future.

We can't help you any further than that, as you're having major problems with an Apple software product, not Cinema 4D or anything to do with MAXON.  I would recommend you follow any instructions and advice that Apple may provide.  I don't know the full extent of system recovery and reset options on Mac OS X, so I wouldn't know what to recommend next.

Joey Gaspe
SDK Support Engineer

On 03/03/2015 at 09:04, xxxxxxxx wrote:

Thank you for your reply Joey.

I will try to do that. In the meanwhile, I managed to make XCode 5.0.1 to work but I still get this error whem trying to compile de cinema4dsdk or my plugin:

Libtool /./lib_api_debug.a normal x86_64
    cd "/Applications/Maxon/CINEMA 4D R15/resource/_api_lib"
    /Applications/ -static -arch_only x86_64 -syslibroot /Applications/ -L/Applications/Maxon/CINEMA\ 4D\ R15/resource/_api_lib/../../../../(build)/Debug -filelist /Applications/Maxon/CINEMA\ 4D\ R15/resource/_api_lib/../../../../(build)/ -o /./lib_api_debug.a

/Applications/ file: /Applications/(build)/ has no symbols
/Applications/ can't create output file: /./lib_api_debug.a (Permission denied)
Command /Applications/ failed with exit code 1

On 03/03/2015 at 09:51, xxxxxxxx wrote:

Hi Rui,

To be clear, my last post is a response to all of your compiler problems, including the one you've just repeated about lib_api_debug.a.  However, I'm curious to know if you tried the find call I described to see if that file exists on your system anywhere?  BTW, /./ is a strange path for it to report, perhaps it's trying to create the file in the compiler's libtool subdirectory, so you might have a path configuration problem in your project file?  That's the best I can think off of the top of my head.

Joey Gaspe
SDK Support Engineer

On 03/03/2015 at 11:25, xxxxxxxx wrote:

The problem is that I didn't performed an "uninstall" because, sinde Xcode 4.3, the application is self-contained and does not require any un-installation.
But I may have some pieces left from an older version. Now, I'm trying to get an older version to install, to be able to run the uninstall script to make sure that everything is cleaned. But I can't find any older version that allows me to install in Yosemite 😞
This is getting really troublesome.

As for the erroneous path... I used the cinema4dsdk.xcodeproj file that I then adjusted to point to my source files and produce a new target. I did everything I used to do to create all my other plugins.
So, how can a path get wrong?

On 04/03/2015 at 00:46, xxxxxxxx wrote:

Here is a video I made to show my problems. Maybe this could shed some light on what is wrong or what am I doing wrong.;

On 04/03/2015 at 09:05, xxxxxxxx wrote:

Hi Rui,

You're video is set to private, I couldn't access it.

Joey Gaspe
SDK Support Engineer

On 04/03/2015 at 09:15, xxxxxxxx wrote:

Damn!!! It was the first time that a video that I upload got a Private status without me doing anything.
It should be public now. 🙂

On 09/03/2015 at 15:58, xxxxxxxx wrote:

Has anyone seen the movie and figured it out what is going on?

I managed to install XCode 5.0.2 in my MacBook Pro and I'm being able to develop and compile there.
But I want to be able to develop and compile on my desktop machine too.
Anyone? Please?

On 10/03/2015 at 21:10, xxxxxxxx wrote:

Hi Rui,

Something I see in your video, but that you don't ever point out, is that you're working under the Applications directory.  Due to OS X security rules and procedures that resemble those in Windows (for the  Program Files directory), I doubt that is where you're supposed to put your project files, let alone build within it.  Please try moving your projects to an appropriate directory on your Mac, check all permissions, and try compiling from there.  You may have to adjust the paths and such in the project file.

Joey Gaspe
SDK Support Engineer

On 11/03/2015 at 07:02, xxxxxxxx wrote:

Thank you Joey.

I have always compiled my plugins with Xcode and Cinema 4D being in the Application folder.
However, after your recomendation, I created a Developer folder inside my user Folder and, inside it I placed the folder of the Cinema 4D that I use for development and the Xcode application.
And I still go this error:

Libtool /./lib_api_debug.a normal x86_64
    cd "/Users/ruibatista/Second Drive/Development/CINEMA 4D R15/resource/_api_lib"
    /Users/ruibatista/Second\ Drive/Development/ -static -arch_only x86_64 -syslibroot /Users/ruibatista/Second\ Drive/Development/ -L/Users/ruibatista/Second\ Drive/Development/CINEMA\ 4D\ R15/resource/_api_lib/../../../../(build)/Debug -filelist /Users/ruibatista/Second\ Drive/Development/CINEMA\ 4D\ R15/resource/_api_lib/../../../../(build)/ -o /./lib_api_debug.a

/Users/ruibatista/Second Drive/Development/ file: /Users/ruibatista/Second Drive/(build)/ has no symbols
/Users/ruibatista/Second Drive/Development/ can't create output file: /./lib_api_debug.a (Permission denied)
Command /Users/ruibatista/Second Drive/Development/ failed with exit code 1

Since this seems to be a problem writing a file inside the Xcode application itself, I even opened the Xcode package and changed all the permissions of ALL folders and files inside it to Read & Write for ALL users (Me, system, admin and everyone).
And I still get the same error 😞

On 11/03/2015 at 07:04, xxxxxxxx wrote:

Oh, another thing.
I used the same project file that I'm using in my MacBook Pro and is compiling just fine.
Actually, I copied the whole plugin folder from my MacBook Pro to my iMac. It compiles fine in Xcode 5.0.2 in my MacBook Pro but the same project returns this error in Xcode 5.0.2 on my iMac.

On 11/03/2015 at 09:51, xxxxxxxx wrote:

Hi Rui,

In previous posts, I asked that you report back on the output of the following command:

find . -iname lib_api_debug.a

You should try it both on your system that works and the one that doesn't.  I think you'll see a difference, and you'll then know which path to change in the project's settings on the troubled system.  You most likely have a path setting issue in the project, as it's trying to output to a path that isn't allowed.

I have no other recommendation or ideas to add...

Joey Gaspe
SDK Support Engineer

On 11/03/2015 at 10:13, xxxxxxxx wrote:

This is what I got in my iMac (the one that is not allowing me to compile) :

Last login: Wed Mar 11 14:44:14 on console
iMac:~ ruibatista$ find . -iname lib_api_debug.a
./Second Drive/(build)/Debug/lib_api_debug.a
./Second Drive/Development/CINEMA 4D R15/resource/_api_lib/lib_api_debug.a
iMac:~ ruibatista$

And this is what I got from my MacBook Pro:

RuiBatistasMBP:~ ruibatista$ find . -iname lib_api_debug.a
find: ./Library/Saved Application State/com.adobe.flashplayer.installmanager.savedState: Permission denied
RuiBatistasMBP:~ ruibatista$

p.s. The Second Drive is a folder, not really a drive.

On 16/03/2015 at 02:30, xxxxxxxx wrote:

Anyone else had a similar problem?
I still can't compile anything in my iMac

On 21/03/2015 at 00:58, xxxxxxxx wrote:

Rui and I had a private discussion of this topic.
In the end reinstalling Cinema 4D solved his problem.

On 21/03/2015 at 03:59, xxxxxxxx wrote:


After re-installing several versions of Xcode, making sure the permissions were all set to Read & Write and even after fixing permissions (with Disk Utility), the only solution was to re-install Cinema 4D.

WOW!! It is so nice to finally be able to build my projects in my main machine.
And, on the positive side, now I also have a portable development machine