HELP!!! Xcode not working [SOLVED]



  • On 18/12/2014 at 02:15, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   15, 16 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    I was using Xcode 4.6.2 to develop for Cinema 4D 15 and 16 (and also for 14, actually).
    I haven't used it for a while (a couple of months) and now, when I try to run Xcode, after it shows up on the menu bar, it suddenly quits. No error messages, nothing. It just quits!!!
    I already tried uninstalling it (using the uninstall-devtools command in the Terminal) and installing it again.
    But it still does the same :-(
    Did this happened to anyone else?
    What can I do? Please, please help me.



  • On 18/12/2014 at 02:29, xxxxxxxx wrote:

    Hi Rui,

    there are three things coming to my mind.

    I once had a similar situation with Xcode 6.0.1, where it refused to start. I'm reluctant to say so, but the final solution was to reboot my MacBook... something I deemed to be a happily forgotten thing of Win98 era.

    For Cinema 4D R16 the recommended Xcode version is at least Xcode 5.0.2. I myself use 6.0.1 without problems. It may well be, that the R16 SDK uses some C++ feature, 4.6.2 is not aware of and which triggers a bug in the old 4.6.2 version. You may want to have a look here for the recommended Xcode versions per Cinema 4D SDK version: PluginCafe Blog: C++
    By the way, you can install several Xcode versions next to each other (best to start installing with the oldest). There are archives with all versions to be downloaded from Apple's developer site.

    Lastly you may want to find out, which was the last project you worked on. Xcode is probably trying to reload this on start. Just to be sure, this is not badly configured, move the project aside, so Xcode can't find it anymore and try to start again.



  • On 18/12/2014 at 04:34, xxxxxxxx wrote:

    Thank you Andreas.
    I will try those solutions when I get home (I'm starting a Cinema 4D class now).



  • On 18/12/2014 at 12:30, xxxxxxxx wrote:

    I can't make Xcode 4.6.2 work.
    I installed Xcode 5.0.2 and when I opened my project in there and pressed "Build", I got this error (and the build failed) :

    Command /Applications/Developer/5.0.2/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool failed with exit code 1

    What can I do to fix this?



  • On 18/12/2014 at 14:55, xxxxxxxx wrote:

    Although I believe I already know the answer, did you get any more information about this error from Xcode?



  • On 18/12/2014 at 15:22, xxxxxxxx wrote:

    Here is a capture of the report:



  • On 19/12/2014 at 01:46, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    Here is a capture of the report:

    Rui,

    the last icon in the navigator menu contains the "Show the Log navigator" icon. If you select one of the message - in the main window - and open the context menu (RMB), then you'll find an option "Expand All transcripts". This should give you a more detailed message of what is going wrong.

    I suppose it 's the incompatible install path we reported for Xcode 5 & newer (@Apple; radar: ID 14771490) - and which is considered in the R16 SDK.

    Another possible problem could be selecting the wrong command line tools (Xcode 5 should always include the right ones); please check in Xcode->Preferences->Locations ... "Command Line Tools" for the proper selection.

    Best regards,

    Wilfried



  • On 19/12/2014 at 15:58, xxxxxxxx wrote:

    Thank you for the added information, Wilfried.
    I managed to be able to perform successful builds from five out of my six C++ plugins. Just have to deal with a small (I hope) error in the last one.
    This is one of the reasons I do most of my development in python. It is so much easier (but not as powerful, I know :-) )



  • On 27/02/2015 at 10:50, xxxxxxxx wrote:

    Damn! Damn! Damn!
    This is happening again.
    Now I tried using the project file I was using for my plugins that were already compiling, changed it to the new source code and I get a compilation fail with the same error as the one stated in my original post.
    I also tried with the cinema4dsdk project file and I get the same error!!!!
    Why? Oh why?!?!?!
    Can someone help me? Please.



  • On 27/02/2015 at 10:53, xxxxxxxx wrote:

    The Command Line Tools are set to Xcode 5.0.2 (5A3005).



  • On 28/02/2015 at 09:19, xxxxxxxx wrote:

    Already tried re-installing Xcode and I still get the same error:

    Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool failed with exit code 1

    I tried re-installing Xcode 4.6.2 and Xcode 5.0.2 and they both return the same error as I try to build my plugin.

    Does anyone know how to fix this?



  • On 28/02/2015 at 13:00, xxxxxxxx wrote:

    I tried installing Xcode 5.1 and now I got this error:

    Libtool /./lib_api_debug.a normal x86_64
        cd "/Applications/Maxon/CINEMA 4D R15/resource/_api_lib"
        export MACOSX_DEPLOYMENT_TARGET=10.6
        /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool -static -arch_only x86_64 -syslibroot /Applications/Developer/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -L/Applications/(build)/Debug -filelist /Applications/(build)/_api.build/Debug/_api.build/Objects-normal/x86_64/_api_debug.LinkFileList -o /./lib_api_debug.a

    /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: file: /Applications/(build)/_api.build/Debug/_api.build/Objects-normal/x86_64/c4d_uuid.o has no symbols
    error: /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: can't create output file: /./lib_api_debug.a (Permission denied)

    Does this help?



  • On 28/02/2015 at 16:58, xxxxxxxx wrote:

    I can't even compile the cinema4dsdk!!!
    I get all these errors :-(



  • On 01/03/2015 at 03:27, xxxxxxxx wrote:

    Has this never happened to anyone?
    I simply can't do anything :-(



  • On 01/03/2015 at 04:52, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    Has this never happened to anyone?
    I simply can't do anything :-(

    Based on the output I'd guess you managed to write protect the sdk and build directory (making Xcode and the toolchain failing to create any compiled files).

    Best regards,

    Wilfried



  • On 01/03/2015 at 05:08, xxxxxxxx wrote:

    When I read the errors, I set all the directories to be Read & Write.
    And, even so, I get the same errors :-(



  • On 01/03/2015 at 05:16, xxxxxxxx wrote:

    After setting the privileges, to Read/Write in the whole Cinema 4D folder and the (build) folder, I still get this error:

    Libtool /./lib_api_debug.a normal x86_64
        cd "/Applications/Maxon/CINEMA 4D R15/resource/_api_lib"
        export MACOSX_DEPLOYMENT_TARGET=10.6
        /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool -static -arch_only x86_64 -syslibroot /Applications/Developer/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.9.sdk -L/Applications/(build)/Debug -filelist /Applications/(build)/_api.build/Debug/_api.build/Objects-normal/x86_64/_api_debug.LinkFileList -o /./lib_api_debug.a

    /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: file: /Applications/(build)/_api.build/Debug/_api.build/Objects-normal/x86_64/c4d_uuid.o has no symbols
    error: /Applications/Developer/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: can't create output file: /./lib_api_debug.a (Permission denied)



  • On 01/03/2015 at 10:41, xxxxxxxx wrote:

    Where exactly is located the /./lib_api_debug.a file that can't be created?
    Just to make sure it is not write protected.



  • On 01/03/2015 at 11:42, xxxxxxxx wrote:

    Hi Rui,

    I'm terribly sorry, I'm currently in the US attending GDC. I'm not sure Joey will find the time to help you out. So probably you'll have to wait a week until I return. Sorry :(



  • On 01/03/2015 at 13:31, xxxxxxxx wrote:

    Ok, thank you in advance, Andreas. I will have some Cinema 4D classes to give this week so I will keep my plugins hibernating, in the meanwhile.


Log in to reply