File text not displaying [SOLVED]



  • On 03/12/2014 at 13:55, xxxxxxxx wrote:

    I have a plugin with FILENAME FILE01_LINK { } in the .res file.

    In the .pyp file I have the following:

    FILE01_LINK         = 1005,

    def Init(self, op) :
            self.InitAttr(op, str, [1005])
    op[1005] = "Test"

    For some reason I can't get any text to display in the file text field, unless I type it in or load a file by clicking on the ... to the right of the file input area.
    When I drag the description text into the console I get: print pluginTest[c4d.FILE01_LINK] OK
    On the next line the console prints Test
    This confirms that my File string is in memory as the value of op[1005], but it is not being displayed to the user.  What could cause this?  I can show more of my plugin if needed.



  • On 03/12/2014 at 14:47, xxxxxxxx wrote:

    Hello,

    is there a reason why you don´t use

      
    self.SetFilename(FILE01_LINK,"test")  
    

    inside your init function?

    Best wishes
    Martin



  • On 03/12/2014 at 15:17, xxxxxxxx wrote:

    Ya know, too often it's the little, overlooked thing that can stump me all day.  Thank you, that worked!

    Thanks again,
    David


Log in to reply