Bitdefender killed my VS projects!



  • On 20/11/2014 at 05:29, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R13-16 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hi,

    I'm still working with VS 2010 on C4D R13 on Win7 64. I run VS in admistrator mode to get access to the standard directories C:/Program Files/MAXON/...

    At Sunday I updated my Bitdefender AntiVirus to Version 2015. Now I can't compile any plugin project in x64 anymore. I uninstalled BD and set up a new untouched sdk project. Unfortunately that all didn't help.

    Compiling 32Bit works, but x64 leads to the errors:

    1>------ Build started: Project: _api, Configuration: Debug x64 ------
    1>Error: The "ConfigurationGeneral" rule is missing from the project.
    2>------ Build started: Project: cinema4dsdk, Configuration: Debug x64 ------
    2>Error: The "ConfigurationGeneral" rule is missing from the project.
    ========== Build: 0 succeeded, 2 failed, 0 up-to-date, 0 skipped ==========

    The property panels are almoust empty when switching to x64. Any ideas?

    _<_img src="http://www.heyne.co/transfer/c4dsdk_properties.jpg" border="0" /_>_



  • On 21/11/2014 at 01:53, xxxxxxxx wrote:

    a quick status report:

    I reinstalled BitDefender 2010
    I used the oppertunity to update to VS2013.

    Adapting VS2010 projects failed, because all the x64 settings were gone(?). VS2013 makes x64 default setting matching desktop apps (exe), so I tried to import VS2005 projects. After just setting the extensions to cdl/cdl64 and the debugger target, it compiled! Puh...



  • On 21/11/2014 at 02:32, xxxxxxxx wrote:

    I moved this to General Discussion, as I don't see any SDK related information in here.


Log in to reply