COFFEE Execution generates Errors



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2002 at 12:18, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   8.012 
    Platform:      
    Language(s) :   C.O.F.F.E.E  ;

    ---------
    Hi all,

    is somebody out ther who can help me please. Tody I tried to use old plugins with R8. Some worked other not. But if I installed some (e.g. AlignAssistant or Multi Target) Cinema crashed sooner or later. Without any Plugins it runs stable. So I deinstalled everything and tried to accomplish the AlignAssistant Functionality by writing my own COFFEE Expression. Everything worked fine several minutes. Than Cinema crashed again.

    Is it possible that the COFFEE Execution is buggy in 8.012?

    Any help is highly appreciated,

    cheers mnu

    P.S.: I think in R8 there are no changes to the COFFEE SDK. But why are there old plugins that don't work with the new Version. If COFFEE is the same, the plugs should work, am I wrong?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2002 at 13:09, xxxxxxxx wrote:

    Quote: Originally posted by mnu on 11  November 2002
    >
    > * * *
    >
    >
    > Is it possible that the COFFEE Execution is buggy in 8.012?
    Like old C++ plugins, C.O.F.F.E.E. plugins are emulated in 8.012. This means that some features won't work. There is currently no updated version of C.O.F.F.E.E. to upgrade the broken plugins to.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2002 at 04:22, xxxxxxxx wrote:

    Thanx Mikael,

    however, COFFEE is my number one reason to use C4D. What did you mean by writing there is no updated COFFEE version. Is there something new under the hood but the documentation is not ready or is COFFEE only available as emulation in R8?

    cheers mnu



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2002 at 10:24, xxxxxxxx wrote:

    Quote: Originally posted by mnu on 12  November 2002
    >
    > however, COFFEE is my number one reason to use C4D. What did you mean by writing there is no updated COFFEE version. Is there something new under the hood but the documentation is not ready or is COFFEE only available as emulation in R8?
    Both. You can find undocumented and unsupported changes under the hood (for example, if you look with a HexEditor you can find some of the new primitive objects like CubeObject instead of the old PrimitiveObject). But most of the new R8 features are not accessible at all from C.O.F.F.E.E., regardless of documentation.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2002 at 12:05, xxxxxxxx wrote:

    Hi Mikael,
    thanx for making this clear. Will COFFEE be updated in the near future? Is XPresso supposed to be the official replacement for COFFEE? Should I try to get into C++ to write my Plugins like I did with COFFEE in R7?
    cheers mnu



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2002 at 13:59, xxxxxxxx wrote:

    Quote: Originally posted by mnu on 12  November 2002
    >
    > * * *
    >
    > Will COFFEE be updated in the near future?
    There have been no public announcements about this issue.
    > Is XPresso supposed to be the official replacement for COFFEE?
    No, I don't think so. They're pretty orthogonal really, so Xpresso couldn't be a replacement for all that C.O.F.F.E.E. offers/offered.
    > Should I try to get into C++ to write my Plugins like I did with COFFEE in R7?
    If you have the resources necessary (compiler + skills), then that is certainly the best way to program plugins for R8 at the moment.


Log in to reply