Help getting the SDK to compile on XCODE



  • On 14/01/2014 at 11:32, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   r14 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    I'm running xcode 5.0.2 on a mac osx10.9 with C4Dr14.  When I try to compile the sdk I get the following error.

    /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool: can't create output file: /./lib_api_release.a (Permission denied)
    Command /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/libtool failed with exit code 1

    Anyone offer any help?

    http://www.jimmycoppens.com



  • On 14/01/2014 at 18:12, xxxxxxxx wrote:

    You shouldn't be doing any builds within the Applications folder - it is write protected!
    Copy the plugins and resources folders from Cinema 4D to your Users folder somewhere and build from there.



  • On 15/01/2014 at 09:12, xxxxxxxx wrote:

    When I move the build out of the plugins directory, the linker can't find the c4d.h files.  In previous versions of c4d I always built in the applications folder.



  • On 19/01/2014 at 06:33, xxxxxxxx wrote:

    Tried to do the same thing but with R13 and OSX 10.8 this week. Noticed the / in front of the filename? It wants to copy it into the root directory of your hard drive. The solution is very simple. Just change the install directory to . and it should work.

    P.S. on my system i also had to correct the directory for intermediate build results. Was very easy as well. It is all right in the build options. I set mine to /Users/mwelter/Libraries/Dev/Blablabla/whatever/the/XCode/default/is



  • On 20/01/2014 at 10:52, xxxxxxxx wrote:

    yup, that was it!  Thank you for the reply!  I can now compile the test plugins!  Thanks!



  • On 21/01/2014 at 07:30, xxxxxxxx wrote:

    Howdy,

    Or just change your permissions. The way I see it is, "How dare my computer tell me , the administrator, that I don't have permission!" 😂

    Adios,
    Cactus Dan



  • On 21/01/2014 at 07:33, xxxxxxxx wrote:

    Cactus Dan!!  Whoa you are awesome man!  I can't believe you are on this forum!  That is fantastic!


Log in to reply