.res not found



  • On 02/01/2014 at 09:47, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   13 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Plugin compiles fine.  When I run in Cinema4D and select my plugin it tells me that Cinema4D cannot find the object.res in the Cinema4D/resource/res/description/ folder.  This seems wrong.  Why would it be looking there instead of in my plugin folder?  Is this something obvious?

    Sorry, new to this.



  • On 02/01/2014 at 11:38, xxxxxxxx wrote:

    Without code it's impossible to say, but yes, you're doing something wrong. You might want to take a look at my site at http://www.microbion.co.uk/graphics/c4d/create_plugins1.htm where I have some worked examples of simple plugins. You should find what you need to get a resource loaded in one of those.

    Steve



  • On 02/01/2014 at 13:10, xxxxxxxx wrote:

    Thanks.

    Sorry, this seems really strange.  It was working fine, then I tried to Archive to create a Release build and then it went wonky.  I tried doing debug builds again and it is still wrong.  It is a one plugin project.  Are their capitalization restrictions in resources?  Doesn't explain the sudden issue but I am at a loss currently.



  • On 02/01/2014 at 14:00, xxxxxxxx wrote:

    In my rush to clean things up I remove the initialization of the resources in the PluginMessage function.


Log in to reply