Unable to load Python Plugin?....C4D R15



  • On 16/12/2013 at 00:37, xxxxxxxx wrote:

    I just downloaded the recursive spline C4D file by Chris Smith from Greyscalegorilla. I'm able to open the file but unable to change any of the parameters (Spline points, Position, Instance Object, etc....) & I also see the python tag has a small 'x' on it. I've tried many suggestions but no fix & I'm really new to Cinema 4D & would love some help, direction or guidance!!!!

    Timo,



  • On 16/12/2013 at 01:30, xxxxxxxx wrote:

    Hi tplove74,

    this forum is for support of the Python API. Please redirect future problems to the developer or website you
    downloaded the file from (so, an Email to Chris or a comment on GSG's website).

    --------------

    So much for the official statement. The problem is that the Python Tag was written for a very old version
    of the C4D Python API. To fix it, change the first two lines of the code in the Python Tag from

    > import c4d
    >
    > from c4d import documents, symbols as sy, utils

    to

    > import c4d
    >
    > from c4d import documents
    >
    > from c4d import utils
    >
    > sy = c4d
     
    Best,
    -Niklas



  • On 16/12/2013 at 01:47, xxxxxxxx wrote:

    Thank you Nicklas!!! That worked!

    Also Thanks for redirecting my comment to the correct forum topic. Will do.

    Once again thank you!!


Log in to reply