_api_x64_Debug.lib not found

On 13/11/2013 at 05:54, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R14 
Platform:   Windows  ;   
Language(s) :     C++  ;

Sorry, I searched the forum and tried all the proposed solution.
However it keeps saying

"LINK : fatal error LNK1104: cannot open file 'D:\Program Files\MAXON\CINEMA 4D R14\resource\_api_lib\_api_x64_Debug.lib'"

What I do:
- I copy a clean cinema4dsdk directory to my plugins directory
- I click cinema4dsdk.sln to open up VS C++ 2010 Express.
- I change to Debug and X64
- Press F7 Build Solution

It starts compiling all the sources and after linking I get above error.
And it is correct, there is no such library to be found. Not in the directory or somewhere else on the disk.

Note: I have installed the MS SDKS V7.1

On 13/11/2013 at 06:25, xxxxxxxx wrote:

You need at least the plugin and resource folders copied (if you use an external location for builds).  Retaining the folder hierarchy is paramount to the project solution.  There are more instances where you will need to copy stuff from the modules folder for more indepth support.

On 13/11/2013 at 06:26, xxxxxxxx wrote:

No, just copied the sdk directory.
Did not put my plugin source in it.

On 13/11/2013 at 06:28, xxxxxxxx wrote:

As I said, you will need the resource folder localized to the project copy in order to build plugins.  Best of luck!

On 13/11/2013 at 06:33, xxxxxxxx wrote:

I thought I had to link the sdk 4 times to get the libraries first:

So no need to add any plugin sources or folders?

On 13/11/2013 at 06:37, xxxxxxxx wrote:

And of course the cinema4dsdk folder has its own res and source subfolders.

On 13/11/2013 at 06:51, xxxxxxxx wrote:

Ok, retrieving a backup version of the sdk seems to solve it.
Perhaps I deleted too much when testing and trying.

Sorry, it did not solve it for R14.

On 14/11/2013 at 02:36, xxxxxxxx wrote:

Ok, sleepless nights, but I solved it!_<_o:_<_o:p_>_o:p>
I managed to screw up the _api project in Deb_<_o:_<_o:p_>_
Apparently I thought it necessary (at one time) to delete everything within the_<_o:_<_o:p_>_roject.
And of course when it is empty, it will not build a _api__<_o:_<_o:p_>_ug.lib.
I took a backup copy from "_api.vcxproj" in the resource\_api_lib folder and now it works again!_le="font-size: 5pt;">

On 14/11/2013 at 04:20, xxxxxxxx wrote:

You really shouldn't be deleting anything in the resource folder.  And if you are using the cinema4dsdk project folder directly, you shouldn't.  Make a copy of the folder, rename it, and then you can remove source and resource files to be replaced by your plugin's files.

On 14/11/2013 at 04:54, xxxxxxxx wrote:

Yes, that is my lesson for today.
Thanks again.