Xcode4.41 won't build c4dsdk



  • On 03/11/2013 at 18:27, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R15 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    This is a strange one.

    As I upgraded to C4D R15 recently I moved all (three) of my plugins in progress from R12 to the new version by plugging my code into a c4dsdk template. All of them compiled fine. All of them worked in R15.

    Today, I am starting to get linker errors. For a test I tried to compile the c4dsdk project and got the same errors (see below). I don't quite know where to start trouble shooting.

    The only factor so far is I have been using xCode4 but when XCode5 came out I installed that also.

    But I am not quite sure what the "Undefined symbols" error means in the context.

    Or could the problem be somewhere in the C4D files?

    Thanks

    Peter

    Undefined symbols for architecture x86_64:
      "GeUserArea::DrawSetTextCol(Vector64 const&, int)", referenced from:
          Function2::DrawCell(void*, void*, void*, int, DrawInfo*, GeData const&) in activeobject.o
      "VectorToHPB(Vector64 const&)", referenced from:
          LookAtCamera::Execute(BaseTag*, BaseDocument*, BaseObject*, BaseThread*, int, EXECUTIONFLAGS) in lookatcamera.o
      "GetCustomDataTypeDefault(int)", referenced from:
          LookAtCamera::GetDDescription(GeListNode*, Description*, DESCFLAGS_DESC&) in lookatcamera.o
      "TagData::GetModifiedObjects(BaseTag*, BaseDocument*, BaseObject*&, int&, Matrix64 const&, double, int, BaseThread* )", referenced from:
          vtable for LookAtCamera in lookatcamera.o
      "AutoBitmap::AutoBitmap(String const&, double)", referenced from:
          RegisterLookAtCamera() in lookatcamera.o
      "TreeViewFunctions::PythonCleanup(void*, void* )", referenced from:
          vtable for Function2 in activeobject.o
          vtable for MyTreeViewFunctions in layershaderbrowser.o
    ld: symbol(s) not found for architecture x86_64
    clang: error: linker command failed with exit code 1 (use -v to see invocation)



  • On 04/11/2013 at 13:54, xxxxxxxx wrote:

    Did you make sure you cleaned the api project (so any dependencies of the sdk project) before recompiling?



  • On 04/11/2013 at 15:19, xxxxxxxx wrote:

    Thanks,
    Good point. I didn't do that but then I wasn't able to successfully build any of the projects - which had all compiled before. Earlier today I deleted and re-installed my Xcode 4.4.1 folder and without a problem the builds succeed again.

    Peter


Log in to reply