Use with other versions

On 01/11/2013 at 08:39, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R15 
Platform:   Windows  ;   
Language(s) :     C++  ;

---------
Thanks to NiklasR, I have created a C++ lib with routines I can call from Python.

Is it possible to use this lib with other version of Ciname 4d?
E.g. I compiled and linked using R14, can I use the lib with R13?

When trying, it fails with a access violation.
I guess I have to compile and link it against R13 in order to use it with R13?

On 01/11/2013 at 09:02, xxxxxxxx wrote:

Yes, indeed, compiling and linking against the correct (R13) sdk solved the issue.

On 01/11/2013 at 09:33, xxxxxxxx wrote:

Plugin binaries are never backwards compatible. Try to compile with the oldest version possible and
recompile for any incompatible later versions (its rather rare that plugins don't work upwards).

Best,
-Niklas

On 01/11/2013 at 11:33, xxxxxxxx wrote:

OK, I'll try. Thanks.