Replacing c4ds python interpreter.



  • On 26/08/2013 at 08:43, xxxxxxxx wrote:

    Hi,

    I was wondering if someone has already (successfully) tried to replace cinemas python interpreter
    and is willing to share his results. I would be interested in not just updating the python version
    (2.6 to 3k for example), but switch to another branch/implementation of python (http://pypy.org/)
    for speed reasons. It should be technically possible as all python derivatives are python 2.6 
    compatible ?

    Happy rendering,
    Ferdinand



  • On 26/08/2013 at 08:45, xxxxxxxx wrote:

    You'd need to built the Py4D extension against these libraries. To a certain extend, it _might_ be
    possible to simply exchange the shared libraries, but if any function signature differs, Cinema will
    crash. This is just a guess, I didn't test it yet.


Log in to reply