memory leaks with standard spline??



  • On 30/04/2013 at 11:40, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   r14 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    hey there,

    while searching for the cause of memory leaks i experienced, i came along the following problem:
    i open cinema and draw any spline into an empty scene and move some of its points. when i close cinema without saving the console spits out memory leaks in BaseSelect.cpp

    here are some of the lines..

    BaseSelect.cpp(585) : 16 Bytes at 00000000109558D0!
    BaseSelect.cpp(585) : 16 Bytes at 0000000010943AD0!
    BaseSelect.cpp(585) : 16 Bytes at 0000000010941050!
    BaseSelect.cpp(585) : 16 Bytes at 00000000109408D0!
    BaseSelect.cpp(585) : 16 Bytes at 000000001094D2D0!
    BaseSelect.cpp(585) : 16 Bytes at 000000001093F050!
    BaseSelect.cpp(585) : 16 Bytes at 0000000010948150!
    BaseSelect.cpp(585) : 16 Bytes at 0000000010955150!
    BaseSelect.cpp(585) : 16 Bytes at 000000001093FE50!
    BaseSelect.cpp(585) : 16 Bytes at 00000000109424D0!
    BaseSelect.cpp(585) : 16 Bytes at 0000000010941850!
    BaseSelect.cpp(585) : 16 Bytes at 000000001093D450!
    48 Blocks
      
      
    *** Potential Memory Leak Detected ***
    

    this seems to me, like cinema itself creates memory leaks and not my plugin, which i didnt use in the scene...

    any ideas??

    cheers,
    Ello



  • On 30/04/2013 at 12:19, xxxxxxxx wrote:

    Hi Ello,

    I can not confirm this using R14.
    No such leaks here.

    regards,
    Remo



  • On 30/04/2013 at 12:28, xxxxxxxx wrote:

    hm, that is really strange. for testing i removed every plugin and tried the thing again. same result. there are memory leaks.



  • On 30/04/2013 at 13:19, xxxxxxxx wrote:

    Hi ello,

    what Cinema 4D Version exactly do you use? 14.041?

    -Niklas



  • On 30/04/2013 at 13:21, xxxxxxxx wrote:

    no, its still 14.034 . the updater didnt pop up so far

    edit, btw checking for updates does search endlessly.



  • On 30/04/2013 at 15:25, xxxxxxxx wrote:

    I can not reproduce this either. I've checked R14.034 x64 on Windows 7. Are you sure this
    is not due to your plugin?



  • On 30/04/2013 at 15:29, xxxxxxxx wrote:

    i have now updated and still have this behaviour.. i have removed all plugins and still the same... very strange. i just draw a freehand spline, move some points here and there. close without saving and get plenty of memory leaking

    if i dont move the spline points, there are no leaks. as soon as points where moved, the leaks appear



  • On 30/04/2013 at 16:37, xxxxxxxx wrote:

    Where did you put your c4d_debug.txt file?

    I think I remember getting those kinds of memory leak errors in R12. When I was putting the c4d_debug.txt file in the main Maxon folder.
    These days I usually put that file in my plugin's folder.

    -ScottA



  • On 01/05/2013 at 00:00, xxxxxxxx wrote:

    really? but when i put it there, the console doesn't pop up



  • On 01/05/2013 at 06:23, xxxxxxxx wrote:

    These days I usually put that file in my plugin's folder.
    This only works if you Debug C4D using visual Studio so C4D will search in you plugin folder.
    If you start C4D normally then it will search in main folder.
    Any way this should not affect memory leaks.



  • On 01/05/2013 at 06:42, xxxxxxxx wrote:

    Btw, one can also use the -debug command line parameter.



  • On 11/05/2013 at 14:34, xxxxxxxx wrote:

    hi, what are your strategies to find what causes memory leaks? even if i comment everything out there still appear memory leaks. and i have no idea what causes them...



  • On 12/05/2013 at 01:00, xxxxxxxx wrote:

    If you commented out everything , it might not be the fault of your plugin. Do you also get the memory
    leaks when your plugin is simply not installed?

    Best,
    -Niklas



  • On 12/05/2013 at 01:32, xxxxxxxx wrote:

    thats the point. as i mentioned at the beginning of the thread. even if the pluginfolder is empty it happens. but it seems that this doesnt happen to many..

    now i am wondering how i can find out more about the sources of memory leaks.. is there the possibility to get information which things has been forgotten to free, etc


Log in to reply