Eclipse users - can you get code folding to work?



  • On 05/02/2013 at 01:06, xxxxxxxx wrote:

    Hi everyone,
     
    I installed Eclipse + PyDev yesterday. Seems very good for developing Python stuff in C4D!
    But I cannot make code folding using the keyboard work.   Can you?
     
    -Ingvar



  • On 05/02/2013 at 22:21, xxxxxxxx wrote:

    Hi Ingvar,

    This question is not related to the Py4D API, please post such questions in the General Discussion Forum next time.

    Whats exactly means "you can't"? You don't find the shortcut or the shortcut doesn't work?

    Best,
    -Niklas



  • On 05/02/2013 at 23:21, xxxxxxxx wrote:

    Hi Niklas,
    Ok, I will try to pick the appropriate group the next time.
    I know the shortcut keys. And I have even configured other keys and tried them. Regardsless - there is just no reaction when I press Ctrl + Numpad_Subtract or Ctrl + Numpad_Add
     
    -Ingvar



  • On 06/02/2013 at 00:56, xxxxxxxx wrote:

    Hi ingvarai,

    I looked after your problem (have to say I never used a keystroke before to fold code) and found the shortcut "Toggle Folding". In Pydev this doesn't work (as you mentioned). So I started a Java project for which Eclipse was made for. In a Java project the shortcut works, but it does exactly what it says: It enables or disables textfolding, it doesn't folds your code. So I think the function you're looking for is simply not existant. Sorry.

    Nachtmahr

    P.S: It's weird to see that all people involved in this thread speak german but communicate in english...



  • On 06/02/2013 at 01:35, xxxxxxxx wrote:

    Hi Nachtmar,
     
    I am not talking about toggling the code folding.
    I am talking about collapsing a code block using one set of keys, then expanding the code block, using another set of keys.
     
    If you go to Window/Preferences/General/Keys and search for Collapse you will find:
    Collapses the folded region at the current selection
    Ctrl+Numpad_Subtract
    __ 
    If you search for Expand you will find:
    Expands the folded region at the current selection
    Ctrl+Numpad_Add
     
    None of these key combinations work, and code folding and expanding using the keyboard is soemthing I use all the time in Visual Studio. Using the mouse (which works in Eclipse) is too cumbersome, too time consuming, fiddling with the tiny nitty gritty small + - icon.
     
    When it is there, I take it for granted that it i supposed to work.
     
    _> P.S: It's weird to see that all people involved in this _
    > thread speak german but communicate in english...
     
    I am Norwegian, but speak fluent German and also write an acceptable German.
    English is the default language here I think, because it will reach a larger audience. But I am really happy that I know German, because many excellent German Cinema 4D video tutorials have helped me a lot.
     
    -Ingvar



  • On 06/02/2013 at 01:49, xxxxxxxx wrote:

    Hi Ingvar,

    I tried your shortcuts in a Java project and there it works fine. In a pydev project the same keys doesn't work. So I suppose that this is a feature which was not integrated in the pydev module.



  • On 06/02/2013 at 02:02, xxxxxxxx wrote:

    Ok Nachtmar,
    then I got it confirmed. Where can I submit a feature request for this?
     
    -Ingvar


Log in to reply