XCode on 10.6.8



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 11:32, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   13 
    Platform:   Windows  ; Mac  ;  Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hi,

    I have just upgraded to snow leopard 10.6.8. I then installed R13 from CD, then started the c4d sdk xcode project (in XCode 3.14). Clicked built. I get errors all over the place like "CoreServices.h" not available, tanf not defined in this scope etc., when it compiles the api. It also doesn't seem to see the STL (<new> not available).

    What could be the possible issue here? I have not touched anything. It should compile without errors I assume? Do I have to set any macro path like in VS2010? Anybody encountered this or knows the source for these errors? R12 version compiles just fine, same system, same XCode version.

    Please advice
    thx



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 11:44, xxxxxxxx wrote:

    Do I maybe need a higher XCode version? I couldn't see a note for this in the docs (only that 10.6 required is stated).



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 12:03, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    Do I maybe need a higher XCode version? I couldn't see a note for this in the docs (only that 10.6 required is stated).

    See R13 SDK documentation: "We recommend using Visual Studio 2005 or higher on the PC and XCode 3.2.6 or 4.1 or higher on the Mac."

    Best regards,

    Wilfried



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 12:10, xxxxxxxx wrote:

    thanks. Will try that then (though 4.1 is not available any longer for snow leopard so 3.2.6 must do it).



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 15:03, xxxxxxxx wrote:

    I upgraded recently from Leopard to Snow Leopard, then installed XCode 3.2.6, and it all worked fine. So if you install 3.2.6 you should be okay.

    I also just upgraded again to Lion in preparation for compiling for R14, and then installed XCode 4.4. It all works okay. Only thing I've noticed is that 3.2.6 seems a touch flaky on Lion, it hung a couple of times and had to be force-shut down, but other than that it seemed okay. XCode 4.4 is really quite nice though.

    Steve



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/08/2012 at 16:16, xxxxxxxx wrote:

    Thanks for sharing your experience Steve. I have installed 3.2.6 and it indeed is all fine now.
    Will have to get Lion too for 4.4 and R14.


Log in to reply