Disabled warnings in the R12 SDK



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 06/06/2011 at 01:57, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R12 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    I noticed, that the R12 API would trigger several compiler warnings, that are simply suppressed bei MAXON!

    In the VS project file "/resource/_api_lib/DebugWin32.vsprops" (which is also the basis for the other configurations like: "DebugWin64.vsprops", "ReleaseWin32.vsprops" and "ReleaseWin64.vsprops") the following is definded:

    DisableSpecificWarnings="4062;4100;4127;4131;4201;4210;4242;4244;4245;4305;4310;4324;4365;4389;4505;4512;4611;4706;4718;4740;4748;4996"

    In older C4D versions it wasn't necessary to disable these warnings.

    I don't know what to think of that!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 06/06/2011 at 04:26, xxxxxxxx wrote:

    I don't think you need to make anything of it. Some of those warnings (like 4062) are disabled by default in the compiler anyway. I haven't looked through all of them but the ones I have looked at were all examples of best C++ programming practice that the coders at Maxon have, I suppose, decided to ignore over the years.

    For example, if you look at 4100, you see that it is generated if a parameter in the parameter list of a function is not used in the function body. This generates warning 4100. My reaction to that is, well it may be (in fact I'm sure it is) best practice not to do that, but really, who cares? The other warning codes I looked at were much the same.

    I don't know why these are formally suppressed in R12 and not in previous versions, but it might be that Maxon are now using VS2008 or VS2010 where these warnings are new. Until quite recently they were using VS2005, and perhaps those warnings weren't present in that version so didn't have to be suppressed?


Log in to reply