LoadDocument ignores Tags



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 24/02/2011 at 07:57, xxxxxxxx wrote:

    I can't get documents.LoadDocument to include the tags, i.e.

    d = documents.LoadDocument('t.c4d', SCENEFILTER_OBJECTS | SCENEFILTER_MATERIALS)
    assert len(d.getObjects()[0].GetTags()) == 0
    

    However, documents loaded via LoadFile include the object's tags, but are rendered (I don't want that, just need some tags in the background). Is this a bug or am I missing something?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 24/02/2011 at 18:32, xxxxxxxx wrote:

    Hi ibbgdv,

    If you pass SCENEFILTER_OBJECTS to LoadDocument, all tags will be loaded and are accessible. If you want to remove all tags from the objects, you can browse through the hierarchy and remove or disable them manually.

    Cheers, Sebastian



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 25/02/2011 at 02:29, xxxxxxxx wrote:

    You're totally right - my code worked all along, but the first object was tag-less. Also, the material associations of texture tags are not kept when copying cross-document. However, a simple search in the list of all materials and a short reassociation is sufficient to fix this.


Log in to reply