Test if rendering in Picture Viewer



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 31/12/2010 at 06:17, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   12 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hi

    I'm updating a video post plugin to R12 and unfortunately BaseVideoPostStruct has changed.

    It no longer has a member  editor_render.   Up to R11.5, this was a BOOL that was TRUE if rendering in the editor.

    Our plugin exports to a file when rendering in the Picture Viewer, so we tested editor_render to avoid creating files for test renders in the editor.

    Is there another way to test if the plugin is rendering in the Picture Viewer?

    CheckIsRunning() doesn't look like a reliable test.  RenderNotificationData has a BOOL called external that is TRUE if the rendering is not in the editor view, but I don't know if a video post plugin can get messages.

    Thanks for any advice!
    David



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 02/01/2011 at 22:23, xxxxxxxx wrote:

    it's now done with flags in VideoPostStruct:
    vps->renderflags & RENDERFLAGS_EXTERNAL



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/01/2011 at 05:39, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    it's now done with flags in VideoPostStruct:
    vps->renderflags & RENDERFLAGS_EXTERNAL

    Thank you, affa, that works fine.

    Make Preview sets this flag too so I'm also testing for RENDERFLAGS_CREATE_PICTUREVIEWER or RENDERFLAGS_OPEN_PICTUREVIEWER to avoid creating a file for each preview frame by default.

    David


Log in to reply