Arbitrary crash on MAC



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/11/2010 at 07:02, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   10.5 
    Platform:   Windows  ; Mac  ;  Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hi,

    I have a customer that has v10.5 and that encounters a crash with the same crash message in the bugreport.txt (see below) on his two machines (both running OSX, 10.5.8 and 10.6.4).

    However, I cannot reproduce any crash neither on my Win nor on my MAC systems. Also I have two testers on MAC and 10.5 and also several other 10.5 customers. None of them can reproduce any crash no matter what they do. It all runs smooth and stable.

    Any idea what the reason could be? :-/

    >OS_Type = OS X  
    
      	OS_Version = 10.6.4  
     
      	Machine_Model = MacPro4,1  
     
      	Processor_Type = unknown  
     
      	Processor_Speed = 2260 MHz  
     
      	Number_of_processors = 16  
     
      	Graphics_card = Vendor: ATI Technologies Inc., renderer: ATI Radeon HD 4870 OpenGL Engine, version: 2.1 ATI-1.6.16  
     
      	Loaded_Plugins = addons expressiontag graphviewcore modeling newman objects shader xtensions advancedrender pyrocluster sky bitmapfilter bp2lw bp2maya allplan browser characteranim compositing dwg dwgobjects fbx6 flashex onlinehelp openexr relaxuv sla dynamics hair ca2 clothilde mocca motiongraphics settings.cof sketch thinkingparticles tpoperators dpit ShadowCatcher.cob libSVI-StereoEditing.1.0.0 Vue7xStream   
     
      }  
     
      ApplicationInfo  
     
      {  
     
      	CINEMA_4D_Version: 10.506  
     
      	Memory(Global) : 75574912  
     
      	Memory(GlobalPeak) : 78939568  
     
      	Memory(Total) : 510  
     
      	Memory(Current) : 272  
     
      	Memory(LowMemCnt) : 0  
     
      }  
     
      Opened Scenes  
     
      {  
     
      	Active Scene: 0x17f47cfc "Ohne Titel 1"  
     
      }  
     
      Exception  
     
      {  
     
      	ExceptionNumber = 0x00000001  
     
      	ExceptionText = "EXC_BAD_ACCESS"  
     
      	Address = 0x932af1b2  
     
      	Thread = 0  
     
      	Last_Error = 0x00000000  
    

    HIToolbox: _IsEventBusy + 0xe (SP: 0xbfffc5b8 PC: 0x932af1b2)

      		HIToolbox:	\_AcquireEventFromQueue + 0x9c (SP: 0xbfffc608 PC: 0x932aef02)  
     
      		HIToolbox:	\_ReceiveNextEventCommon + 0xd6 (SP: 0xbfffc678 PC: 0x932aacc5)  
     
      		HIToolbox:	\_ReceiveNextEvent + 0x53 (SP: 0xbfffc6b8 PC: 0x934331e3)  
     
      		CINEMA 4D:	\__Z12_GeDoUpdatesv + 0x68 (SP: 0xbfffc708 PC: 0x7bc6)  
     
      		CINEMA 4D:	\__ZN14ProgressGadget9CbMessageERK13BaseContainer + 0x2df (SP: 0xbfffc7c8 PC: 0x690ccb)  
     
      		CINEMA 4D:	\__ZN17GlobalProgressBar9CbMessageERK13BaseContainer + 0x73 (SP: 0xbfffc808 PC: 0x704d4d)  
     
      		CINEMA 4D:	\__ZN16GlobalStatusList9DoMessageERK13BaseContainer + 0x33 (SP: 0xbfffc848 PC: 0x6fa4ad)  
     
      		CINEMA 4D:	\__Z24SystemCoffeeSetStatusBarRK13BaseContainer + 0x2e (SP: 0xbfffc868 PC: 0x6be6d0)  
     
      		CINEMA 4D:	\__ZN10EmuManager7MessageElmmm + 0x1ff (SP: 0xbfffc8a8 PC: 0x71f0ab)  
     
      		CINEMA 4D:	\__Z14AsyncHandleMsgP13BaseContainerP10BaseWindowPPv + 0x90 (SP: 0xbfffc8e8 PC: 0x71948c)  
     
      		CINEMA 4D:	\__Z15AsyncReceiveMsgP13GeWinGMessage + 0x71 (SP: 0xbfffc908 PC: 0x719ae9)  
     
      		CINEMA 4D:	\__Z10MyCallBackP5GeWin12GeWinMessagePv + 0x156 (SP: 0xbfffc9f8 PC: 0x72f754)  
     
      		CINEMA 4D:	\__Z18_GeWinSendGMessageP5GeWinmPvS1_P10BaseThread + 0x75 (SP: 0xbfffca48 PC: 0xe269)  
     
      		CINEMA 4D:	\__Z12AsyncSendMsgRK13BaseContainerP10BaseWindowP10BaseThread + 0xa0 (SP: 0xbfffca78 PC: 0x71995a)  
     
      		CINEMA 4D:	\__ZN10EmuManager13StatusSetTextERK6String + 0x83 (SP: 0xbfffcac8 PC: 0x72652f)  
     
      		CINEMA 4D:	\__Z14XStatusSetTextPK6String + 0x25 (SP: 0xbfffcae8 PC: 0x4135bb)  
    

    dpit.dylib: __ZN5Fluid11WaterSolver19make_incompressibleEv + 0x5c (SP: 0xbfffcd08 PC: 0x1fd8624c)

      		dpit.dylib:	\__ZN5Fluid11WaterSolver13SimulateFluidElflilb + 0xd8b (SP: 0xbfffcdf8 PC: 0x1fd5b95b)  
     
      		dpit.dylib:	\__ZN14FluidSimulator12UpdateFluidsEP13BaseContainerP10BaseObjectRKbS5_S5\_ + 0x62f (SP: 0xbfffceb8 PC: 0x1fbefa6f)
    


  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/11/2010 at 09:20, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    <ADDRESS>
    User Information:
    Cinema 4D Version:   10.5 
    Platform:   Windows  ; Mac  ; 
    Mac OSX  ; 
    Language(s) :    
    C++  ;

    ---------
    </ADDRESS> Hi,I have a customer that has v10.5 and that encounters a crash with the same crash message in the bugreport.txt (see below) on his two machines (both running OSX, 10.5.8 and 10.6.4).However, I cannot reproduce any crash neither on my Win nor on my MAC systems. Also I have two testers on MAC and 10.5 and also several other 10.5 customers. None of them can reproduce any crash no matter what they do. It all runs smooth and stable. Any idea what the reason could be? :-/

    Most likely a memory trasher as it crashes in the OS code for receiving the next event (and the structures used there seem to be damaged). Installed are these 3rd party plugins:

    - dpit
    - ShadowCatcher.cob
    - libSVI-StereoEditing.1.0.0
    - Vue7xStream

    You can track it down by removing them one by one. Also pay attention (as they are not listed here) to installed system enhancers and Quicktime codecs (e.g. the DivX 6.7 has a bad memory trasher bug that can crash every 32 bit app - it even happens with the DivX installer, if you have a look at system log file...).

    Best regards

    Wilfried Behne



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/11/2010 at 09:23, xxxxxxxx wrote:

    If I was being particularly cynical I'd say that running Vue 7 xStream on a Mac is asking for trouble (weren't the earlier Mac versions particularly unstable?).

    Has he tried removing that and if so does the crash still happen?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/11/2010 at 09:47, xxxxxxxx wrote:

    thanks.

    dpit is my plugin but it also crashes for him with the same message when all other plugins are deinstalled.  I will check back with him for those system enhancers, maybe we are lucky and it´s one of those.

    I´ll report back.

    thx



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/11/2010 at 03:06, xxxxxxxx wrote:

    ok, here comes mr. strange again. He actually found something. He removed the http://www.perian.org/ application and then the plugin worked for about an hour just fine! Then he got the same crash again and now it´s not working anymore again.

    So there indeed seems to be an issue with the memory somehow, otherwise I cannot explain why this happens. Could it be a general memory problem on the machines due to previous installations of such "system enhancers" which are not fixable by simple deinstallation?

    It seems kind of weird to me that it works for an hour and gets corrupt after another crash again. This doesn´t sound like a "normal" crash behavior to me or am I misinterpreting this? :-/

    Thanks



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/11/2010 at 03:15, xxxxxxxx wrote:

    Originally posted by xxxxxxxx

    ok, here comes mr. strange again. He actually found something. He removed the http://www.perian.org/ application and then the plugin worked for about an hour just fine! Then he got the same crash again and now it´s not working anymore again.So there indeed seems to be an issue with the memory somehow, otherwise I cannot explain why this happens. Could it be a general memory problem on the machines due to previous installations of such "system enhancers" which are not fixable by simple deinstallation?

    Perian is another component (like DivX) that adds QT codecs and these can crash 32 bit apps (as r10.506 was).

    It is unlikely, that this is a hardware problem, as the MacPros contain ECC ram (and you would see damaged ram in the system profiler or the console.app). Its more likely, that his system contains other components (e.g. DivX, DefaultFolderX or other extensions, that hook into OS calls/functions ) that he hasn't told you about (yet).

    Best regards,

    Wilfried Behne



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/11/2010 at 03:50, xxxxxxxx wrote:

    thanks for the further explanations Wilfried. Ok, then I advise him to keep on searching. At least we are on the right track.

    Thank you!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2010 at 05:28, xxxxxxxx wrote:

    Just an idea, there was an issue with plugins crashing under 10.5 when they were compiled with 10.1x . It involved the call of GetCurve().

    See this thread.

    https://plugincafe.maxon.net/topic/1169/499_extending-coffee-string-functions

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/11/2010 at 05:31, xxxxxxxx wrote:

    Thanks for the hint Matthias. Unfortunately I am always compiling with the actual c4d version and am not using GetCurve().


Log in to reply