Create my own Xpresso node



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2010 at 03:03, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   11.5 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hello,

    i like to create my own Xpresso node as an plugin, but I don't know which plugin type I must using?
    NodeData ?

    regards
    Markus



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2010 at 03:39, xxxxxxxx wrote:

    XPresso node plugins are derived from GvOperatorData. Unfortunatly there is no SDK example of XPresso nodes but there is some information and examples in the forum.

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2010 at 07:11, xxxxxxxx wrote:

    thanks,
    ok I'm create my node data and register it with RegisterNodePlugin(....).
    But where appears this new node? In which menu can I find it. I thought, that I find it in the X-Pool.
    ???



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/11/2010 at 07:29, xxxxxxxx wrote:

    Instead of RegisterNodePlugin use GvRegisterOperatorPlugin which also takes the group ID as argument where you want to make your node available.

    For instance: GvRegisterOperatorPlugin(..., ID_GV_OPCLASS_TYPE_GENERAL, ID_GV_OPGROUP_TYPE_GENERAL, ID_GV_IGNORE_OWNER, ...)

    Cheers, Sebastian



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2010 at 00:01, xxxxxxxx wrote:

    find, it works.
    thanks a lot.

    Cheers, Markus



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/11/2010 at 04:18, xxxxxxxx wrote:

    hi again,

    now I try to add more and more functions. Also the port menu with the FillPortsMenu(..) function.
    I see the new menu entry, if I select the corner of my node with the mouse. But if I select one of this menu entries, i get a cinema4d alert from gv_nodedata.cpp file. Also the debugger stopped with an message "C4D has triggered a breakpoint". I don't know what's wrong. Has someone an idea?

    cheers, Markus


Log in to reply