Render camera



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 06/10/2010 at 02:17, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   11.5/12 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    Hello all,
    i have a problem on my videopost plugin.
    i use videopost to export current document and send scene to an external renderer.
    i need to export all camera in the scene and "mark" the active camera.
    now i am making a recursion in real document and if i find a camera i export it and after i check if is the current render camera with:
    if ( mycam == bd->GetSceneCamera(Mydoc)) exporter.setscenecamera(mycam)
    where my cam is the BaseObject i am exporting.
    but my cam and bd->GetSceneCamera(Mydoc) have alwaise 2 differentpointer, and my plugin don't work :(
    why this ?
    is the scene camera from basedraw internaly cloned?
    if yes is there a way to have a link to original camera object from the doument?

    thanks in advance
    Franz



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/10/2010 at 02:07, xxxxxxxx wrote:

    From where do you get mycam? Where in the code do you compare the cameras and where do you get the Basedraw from?

    In a video post effect you can access the camera through the VolumeData (if it is avaible). VolumeData::GetRayCamera. RayCamera has also a link to the real camera, RayCamera::link.

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 07/10/2010 at 05:52, xxxxxxxx wrote:

    thanks :)
    i solved... my mistake i was get the cameras from 2 different document

    Bets
    Franz


Log in to reply