Reset Parameter Crash



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2010 at 13:22, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   11 
    Platform:    Mac  ;  
    Language(s) :     C++  ;

    ---------
    Was working on my plugin when I noticed a very annoying bug pop up, that wasn't there in previous versions.  Whenever I right click on a parameter to reset it to default, c4d crashes.  I tried getting rid of my code in the Init function (since I figured this is what's called when one right clicks to reset a parameter) and getting rid of the GetDEnabling function (recently added) with no luck.  I've been able to track it down to somewhere in my source files (replaced my source files with the previous version, leaving the updated res folder in tact).

    I'm in the process of "re-doing" all my recent revisions in an attempt to track down the problem, but it would be nice to have a little more info about what's going on behind the scenes when someone right clicks to reset a parameter in the AM.  Could save me several hours of work;)

    thanks,
    kvb



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/03/2010 at 14:08, xxxxxxxx wrote:

    OMG... I am so relieved right now:D  Luckily I discovered the issue within my first 5 tests... I flipped a coin to see whether I'd start at the top or the bottom of the list of changes, and if it hadn't come up heads, I'd have been at this for hours.

    The fix is actually kind of embarrassing... let's just say I mucked up filling a variable;)

    kvb


Log in to reply