Using a 64-bit DLL



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 21/02/2010 at 16:59, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   10.5 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hey Everyone,
    I'm having a weird issue with Cinema not loading a 64-bit DLL. Basically I'm using a C++ library for my plug-in. It works just fine on the 32-bit version of Cinema. However, the 64-bit version of Cinema will not load the DLL causing my plug-in to crash.

    I do know that I can't access a 32-bit DLL from a 64-bit application, so I have two DLL's for each version of Cinema. No matter what I try I can't get Cinema(64-bit) to load the DLL.

    Does anyone have experience using DLL's on both platforms of Cinema that could shed some light on what I'm doing wrong? It would be very much appreciated.

    Thanks in advance,
    Josh



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 22/02/2010 at 05:44, xxxxxxxx wrote:

    DLLs are ugly anyway. Can't you compile the library into the plugin binary?

    Cheers,
    Jack



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 22/02/2010 at 21:31, xxxxxxxx wrote:

    Yeah, they seem to be quite a headache. Compiling it all into the plug-ins binary worked fine.

    Thanks,
    Josh


Log in to reply