Plugin too old ?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/10/2009 at 00:39, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R11.5 
    Platform:      Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    While testing with the R11.5 demo, a couple of plugins which work fine in R11 are not loaded, not even in 32-bit mode. This affected both some of my own and others plugins.

    The console says: "...could not be registered (plugin too old)"

    What does that mean and what to do to fix it?

    Thanks

    Kabe



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/10/2009 at 02:24, xxxxxxxx wrote:

    Please download the CINEMA 4D SDK documentation for release 11.5. The chapter "Changes since 11.026" lists most changes done since CINEMA 4D R11.026.

    Plugins which have to be recompiled:
    - Channel shader plugins
    - Material plugins
    - Videopost plugins

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/10/2009 at 04:59, xxxxxxxx wrote:

    I have read that... but I was not aware that this was causing that error message.
    It's also not self-evident that the application itself doesn't run "older" plugins anymore.

    The SDK doc says that a hybrid SDK can not be compiled any more. Is there any way to deliver pre-11.5 and 11.5 plugins in one package, or do we have to deliver separate packages/dylibs now?

    Thanks

    Kabe


Log in to reply