VPBuffer GetLine / SetLine Dithering



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 01/02/2009 at 21:24, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   10.5 
    Platform:    Mac  ;  
    Language(s) :

    ---------

    24 bit dithering is turned off in render preferences.

    Using GetLine / SetLine with dithering flag set to false.

    Why would C4D still dither using a videop[ost plugin when rendering to 8bpc? It does noth dither if I remove the videopost plugin.

    The dithering goes away with 16bpc ( or i assume the precision is great enough to become indistinguishable ).

    thanks,
    David Farmer
    coreaudiovisual



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 02/02/2009 at 03:28, xxxxxxxx wrote:

    Sorry Ican't confirm, it seems to work fine here. Can you describe your test setup please?

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 02/02/2009 at 08:18, xxxxxxxx wrote:

    Everything works as expected unless I use GetLine / SetLine. When the pixel data is altered the pixels are dithered when they are put back. The client is rendering 16bpc so it isn't a huge problem for this production.

    Could be an issue in the future so I will test it against 11 when it arrives. If it is a problem I will publish an example illustrating the problem.


Log in to reply