problem with expression refresh

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 27/10/2008 at 16:16, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   11 
Platform:    Mac  ;  
Language(s) :

---------
Hi all,
i have some problem to with my expression tag plug in,
in particular i am porting my plugin on mac and expression don't works execute code if i not click on any part of interface after my operation.
i have no problem on win my code in execute is :

> <code>
> BaseContainer *data = tag->GetDataInstance();
>      BaseContainer *Odata = op->GetDataInstance();
>      BaseList2D * crd = Odata->GetLink(IDC_OTAKEMANAGER_CURRENTRD,doc,0);
>      if ( crd ==NULL)
>      {
>      RenderData * RD = doc->GetActiveRenderData();
>      BaseContainer * rddata = RD->GetDataInstance();
>      rddata->CopyTo(data,NULL);
>      
>      }
>      
>           return EXECUTION_RESULT_OK;
> </code>

Thanks
Franz

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 27/10/2008 at 16:38, xxxxxxxx wrote:

ok,
after some test......... on win i have the same problem.
and in particular if render settings window is locked in to interface no refresh is done if i don't close it.
on 10.5 all works fine, what i make wrong ?

Thanks
Franz

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 28/10/2008 at 15:52, xxxxxxxx wrote:

ok,  😞
no reply, normal on plugincafe for me !
by the way i my problem is to read if renderdata is changed. is there a message to do this?
whi my expression don't work on 10.5 works gooooood

best
Franz

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 29/10/2008 at 01:19, xxxxxxxx wrote:

Sorry for the delay, I am currently busy finalizing the R11 SDK docu.

What are you doing in your expression? As far as I can see you copy the container from the active renderdata to the tag's container. I guess you somehow manipulate the renderdata. Unfortunatly I can't see much from your posted code.

cheers,
Matthias