XCode, Cocoa and 64 bit in R11?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 06:03, xxxxxxxx wrote:

    Hi :)

    I have one dylib file, that contains the 32 bit and 64 bit plugin, but I would not promise that you can compile it on a 32 Bit mac, like kattkieru wrote...

    Bye



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 06:14, xxxxxxxx wrote:


    Click for full size - [color=#A7A7A7]Uploaded with plasq's Skitch[/color]

    It's there. Or you can do it on your own from the command line by specifying architectures with the -arch flag with GCC and then using LIPO to put all the binaries together.

    The build system has no relation to the target system, since XCode installs multiple cross-compilers. So Dan, that's where you need to go to check.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 06:43, xxxxxxxx wrote:

    Howdy,

    OK, this is what I see on my machine:

    So it appears that the R11 cinema4dsdk project is already set up to compile a "Release" for all versions as a super fat binary: ppc, ppc64, x86_64 and i386.

    Thanks for your help.

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 06:45, xxxxxxxx wrote:

    @ kattkieru: Ah, good to know, thanks for this info.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 06:57, xxxxxxxx wrote:

    That sounds like an easy fix. Expected that new builds would be in order for R11 anyway. Thanks for the information!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 11:38, xxxxxxxx wrote:

    Howdy,

    OK, I've got the sdk compiled for 64 bit and tested on a friends machine. :o)

    Thanks for all the help.

    I'm curious though, since my R9.6 compiled plugins still function in R11 32 bit, can I just compile an R11 64 bit alone and add that into the folder so there'd be a myplugin.dylib and a myplugin64.dylib? That way users who aren't going to upgrade to R11 won't have to be concerned about downloading the right version, because they'd all be in one folder.

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 12:51, xxxxxxxx wrote:

    Quote: Originally posted by Cactus Dan on 13 August 2008
    >
    > * * *
    >
    > Howdy,
    >
    > OK, I've got the sdk compiled for 64 bit and tested on a friends machine. :o)
    >
    > Thanks for all the help.
    >
    > I'm curious though, since my R9.6 compiled plugins still function in R11 32 bit, can I just compile an R11 64 bit alone and add that into the folder so there'd be a myplugin.dylib and a myplugin64.dylib? That way users who aren't going to upgrade to R11 won't have to be concerned about downloading the right version, because they'd all be in one folder.
    >
    > Adios,
    > Cactus Dan
    >
    >
    > * * *

    Having two seperate plugins sucks! If you really want to make the 32 bit part of your plugin work with R9.6 and want to support 64 bit for R11, you could modify your project so that it includes the R9.6 headers for the 32 bit part and the R11 headers for 64 bit. The easiest way to do so would be to set per architecture header search paths in Xcode. Furthermore you'd have to link against the R9.6 and the R11 libs (don't forget to modify the R11 api project to build 64 bit only).

    This way you'd get one plugin supporting R9.6 and R11 and users wouldn't have to worry at all.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 16:38, xxxxxxxx wrote:

    Two plugins doesn't bother me, coming from a Maya background... Every release of Maya requires its own SDK build and a special plugin based on the SDK.

    The real question is whether or not C4D is smart enough to skip over the plugins of the wrong architecture without complaining. If it popped up a message every round saying that the plugin required 64 bit mode, or something, I'd find it annoying. Dan, since you have multiple versions up and running (and you have R11 already! I'm jealous. ;), can you run the test and see what happens if you have the 32-bit and 64-bit versions hanging around?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/08/2008 at 16:51, xxxxxxxx wrote:

    Howdy,

    Actually, I only have R11 demo, but the api files are included so I can start compiling and testing. My machine is only a 32 bit machine, so I've tested my current release plugins with that, and they work fine. A friend of mine has a 64 bit Mac, so he also downloaded the R11 demo and told me that my current release plugins do not show up in 64 bit mode. So, I compiled the R11 sdk and sent that to him, and that shows up in the plugins menu in 64 bit mode.

    The next step would be to compile my plugins. ;o)

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 14/08/2008 at 10:03, xxxxxxxx wrote:

    Forgot to ask: Which version of Xcode are you using here?

    I'm currently on 2.4.1 but realize that it is up to 3.1. Will I need to upgrade Xcode for the 64-bit target support?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 14/08/2008 at 10:12, xxxxxxxx wrote:

    Howdy,

    Yes, you might have to upgrade OSX to 10.5 leopard, too, to get 64 bit compiles. I'm not exactly sure on that. I upgraded my laptop to leopard and XCode 3 and that's the only place I see the 64 bit options. I haven't upgraded my other XCode on tiger.

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 14/08/2008 at 11:12, xxxxxxxx wrote:

    I have 10.4.11 and 10.5.4 (external boot drive) so I'm covered. Yeah, I suspect that Xcode 3 might be needed here and that requires Leopard so, oh boy. ;)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/08/2008 at 07:29, xxxxxxxx wrote:

    Please note that you have to use OSX 10.5 for compiling. Your plugins will run on 10.4 though. The xcode projects for R11 have been updated for XCode 3.1.

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 03/09/2008 at 03:31, xxxxxxxx wrote:

    Hi Matthias,

    I have another question. Can I simply copy my old 10.5 XCode project into R11 plugins folder and modify manually the settings to fit XCode 3.1? What changes need to be done?

    The reason is, I don´t want to build up all my files (and hell, I have a looooot of files and folders in my project) again.

    Thanks in advance for an info.
    Best
    Samir



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 04/09/2008 at 03:45, xxxxxxxx wrote:

    Hi Samir,

    Actually there no changes needed. Just make sure you build the API libs if necassary and check if the Based On setting fits your project build.

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 05/09/2008 at 00:54, xxxxxxxx wrote:

    ah ok. Thanks Matthias!


Log in to reply