CDL in Mac



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/03/2008 at 19:22, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9.1 
    Platform:   Windows  ;   Mac OSX  ; 
    Language(s) :

    ---------
    Hi ...

    I have some plugins that I developed in Windows. If I want to use them on OS X 10.2 ... how can I? Is there any converter or just copy and paste?

    Thanks & regards ...
    Zaw Min Tun



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/03/2008 at 21:38, xxxxxxxx wrote:

    Nope. Just like applications or dynamic libraries (which is what Cinema 4D plugins are), they need to be built specifically for the processor and OS. The .cdl will only work with Windows 32-bit (or 32-bit Cinema 4D on Windows 64-bit). To build plugins that work on MacOS, you need a Mac and Xcode (free) in order to build .dylib (Universal Binary dynamic library plugins). The worst part is if you need to build MacOS Classic plugins (.xdl) since these require CodeWarrior MacOS Classic (hard to get and not free). I think that the lowest version of MacOS X required to support Universal Binary plugins with Cinema 4D is 10.3.9.

    As far as I know, there is no avenue for creating MacOS UB plugins in a Windows environment.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 30/03/2008 at 22:49, xxxxxxxx wrote:

    Hi ...

    Thanks a lot for the information ...

    Regards ...
    Zaw Min Tun


Log in to reply