create 64 bit plugin issue



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/03/2008 at 20:44, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R10 
    Platform:   Windows  ;   
    Language(s) :

    ---------
    I can build my plugin (.cdl) 32 bit have successfully and have been worked fine  on the os pltform(windows),  I was rebuided it to 64bit by vs2005( x64) and output file renamed xx.cql64, the result same to 32bit  (have successfully  ), but 64bit plugins working to crash my applicate and show me error message when I run to the 3d application (CINEMA 4D 64bit.exe) ,    the 32 bit plugin (xx.cql) can working fine but the 64 bit plugin going wrong, why?
     
    #include "TSPlugin.h"
    #include "c4d.h"
    #include "c4d_symbols.h"
    #define ID_Saveto 1021037

    class SavetoTentacles : public CommandData
    {
     public:
      virtual Bool Execute(BaseDocument *doc);
    };
    Bool SavetoTentacles::Execute(BaseDocument *doc)
    {
     CallSave();
     return true;
    }
    Bool RegisterSaveToTentacles(void)
    {
     // decide by name if the plugin shall be registered - just for user convenience
     String name=GeLoadString(IDS_SaveToTentacles); if (!name.Content()) return TRUE;
     return RegisterCommandPlugin(ID_Saveto,name,0,NULL,String(),gNew SavetoTentacles);        ///////I debug the code found error code here
    }



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/03/2008 at 21:12, xxxxxxxx wrote:

    _api_v8   one and the same for the 32bit and 64 bit ?


Log in to reply