VisualC++2008 Debugging?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 10/02/2008 at 14:58, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   10.111 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Hello all.

    For i am a complete noob regarding cplusplus and the cinema sdk
    i don't get vcplusplus to run in debug mode with my plugin.
    The plugin compiles without errors and runs fine with
    release and debug settings. But when i want to start the
    debugger, with cinema4d.exe set, i get the message:
    "Debug Information for Cinema 4D.exe cannot be found or
    does not match. Symbols not loaded."
    Could anyone please tell me as detailed as possible how
    to set the thing up working? Thanks alot.

    Yakuza



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/02/2008 at 01:29, xxxxxxxx wrote:

    There will be only debug symobols loaded for your plugin not for Cinema. You would need a Cinema debug version for this. But you don't want to debug Cinema anyway ;)

    Btw. did you install the VS2005 plugins from the Plugincafe? They include two little helper plugins for developing Cinema plugins.

    cheers,
    Matthias



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 11/02/2008 at 18:11, xxxxxxxx wrote:

    Hi Matthias,

    of course i don't want to debug cinema - maybe i should ;)
    Anyway the problem was a different one: debugging mode
    didn't start up cinema, it just stopped before cinema
    was loaded, so i was noobishly confused about that
    message i posted. Now that i reinstalled cinema4d,
    compiled api and sdk again and installed the helper dlls
    i finally get the expected results: cinema starts up and
    i can see memory contents. :D

    Tanks for your reply, i'll be back soon with some bugs
    to be fixed...

    Yakuza


Log in to reply