cinema4sdk build fails for Release target

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 20/11/2007 at 13:42, xxxxxxxx wrote:

User Information:
Cinema 4D Version:   R10.5 
Platform:      Mac OSX  ; 
Language(s) :     C++  ;

---------
The default cinema4sdk XCode project fails in XCode 2.4.1 when compiling the release configuration due to 2 errors during linking:

Undefined symbols:
__keymgr_get_and_lock_processwide_ptr
__keymgr_get_and_lock_processwide_ptr_2
__keymgr_set_and_unlock_processwide_ptr
_calloc
...

internal link edit command failed

What is the issue andwhat can be done?

Thanks

Kabe

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 20/11/2007 at 14:57, xxxxxxxx wrote:

Hmm, is there a new XCode version? I am not sure which one I got, but I think I have the latest version and I didn´t have any problems compiling the SDK either in Debug or Release. 😕

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 23/11/2007 at 15:18, xxxxxxxx wrote:

Are you using a PPC Mac (G4, G5)? There is a problem with Cinema4D 10.5 SDK and PPC Macs. You have to change the Target SDK in Project settings from Mac OS to Mac OS X 10.4, see picture.

cheers,
Matthias

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 20/07/2008 at 01:23, xxxxxxxx wrote:

Well, that was it! Thanks!

THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

On 20/07/2008 at 10:17, xxxxxxxx wrote:

How does this affect plugins generally? I'm using 'Current Mac OS' (on an Intel Mac with OS 10.4.11). Should I change the Project setting here to 'Mac OS X 10.4 (Universal)'?