Troubles getting SDK to work on Mac



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/01/2007 at 11:59, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   10 
    Platform:    Mac  ;  
    Language(s) :     C++  ;

    ---------
    hello all,

    I'm not sure if there is a already topic about this, but i'm having some troubles to get c++ SDK 9.6 to work on Mac.

    The migration to xCode in help says that i need at least xcode version 2.2.1 and i'm running 2.4.1, so it can't be that. The migration also says that i need to make duplicate of the original 'cinema4dsdk.xcodeproj' and rename it to something else. Well i have done that. But then comes the main problem. The xcode wont open '.xcodeproj' files, it only open '.xcode' files, and if i change the extension and try to open it, i got few error messages and the compiling is out of a question.

    Has anyone come across anything like this? Have i missed something? I'll would be very grateful to any help!

    -Tim



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 14/01/2007 at 14:34, xxxxxxxx wrote:

    Hmm, I am also using the latest XCode 2.4.1 with the 9.6 SDK and my XCode opens the .xcodeproj file without any problems. I am not really a MAC guy but I suppose it should work. :-/



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 15/01/2007 at 22:53, xxxxxxxx wrote:

    Hi all,

    well i founded one solution. which was actually kinda stupid. Although the xCode says it is version 2.4.1 there was some problems to open .xcodeproj files. Well the solution was just to download the same version from Apple's developer center and install it again, and now everything works. There were probably some problems on earlier upgrades or something.

    -Tim


Log in to reply