COFFEE stops and locks in R10



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/11/2006 at 10:53, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   R10 
    Platform:      Mac OSX  ; 
    Language(s) :   C.O.F.F.E.E  ;

    ---------
    I have had two incidences where two different coffee expression pluginTags suddenly stops working in R10 and are at wits end debugging it.
    I have one saved scene from a client where the plugin is impossible to "wake up".
    The plugin is written and compiled in R9.6 and he is running that compiled version (cob).
    I can open the scene using the original uncompiled (.cof) and the plugin is "dead".
    I put in "println("hey there") as the very first line, reloaded the plugin and it is not printed out in the Console.
    I then compiled it in R10 to get a cob file, but it is still dead.
    Adding a new instance of the plugin to another object in the scene is no
    problem.
    I can copy the plugin, delete the original plugin, load a new instance and copy the animation (user data sliders attached to the tag) to the new instance and it works again.

    Are we looking at a update problem in R10 regarding coffee?
    Any thoughts most welcome.

    Cheers
    Lennart



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/11/2006 at 12:01, xxxxxxxx wrote:

    Could you try if this happens with an C.O.F.F.E.E. expression plugin, even a simple dummy plugin? Perhaps there's something wrong with the plugin tag importer for C.O.F.F.E.E. expression plugin tags from previous versions.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 23/11/2006 at 13:42, xxxxxxxx wrote:

    Hi Mikael.
    I haven't tried a regular Coffe expression plugin. But I have sat for two days trying to get an exact replication of the clients scene to break, but no..
    it runs fine.
    In a mail he wrote that before it happened to him, he was adding the Tag to the LayerSystem, and at another point he was changing the radius of a CircleSpline. (The plugin moves a object along splines).
    So he wasn't actually "doing" anything with the plugin directly.

    The second incidence it was refering to, is a completely different plugin
    (thou still a coffee expression plugin tag with userdata attached to it).
    This one scales a op , one axis controlling the other two ("squashing").
    It has a linkfield to put a object in that can externaly scale the op.
    This one have actually stopped for me at one try, but no info in the Console.
    And I did miss saving the scene.
    This plugin have also being reported not to "work" (it was given away at CGTalk) by one user on IntelMac.
    Is it possible for Maxon to look "deeper" into a scene file?

    Cheers
    Lennart


Log in to reply