Still can't get a 64bit version compiled



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 27/09/2006 at 12:52, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9.x 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    Howdy,

    I'm still having problems getting a 64bit version of the cinema4dsdk project compiled. I'm using MS Visual Studio 2005 Standard, which can compile for 64bit. It compiles ok, but I get linker errors. The errors are "unresolved external" either LNK2001 or LNK2019.

    I've followed the 64bit migration pdf file to a tee. I'm pretty sure I haven't missed anything there, but I still can't get the cinema4dsdk project to compile without those linker errors.
    Here is a text file with the list of errors:
    http://www.cactus3d.com/LinkErrors.txt

    I'm not sure what to do to fix that. I would've thought the cinema4dsdk project should compile right away.

    One thing I notice is that the 64 bit migration pdf says to set the configuration to "All Configurations and the platform to x64 and I do that, but everytime I open the porperty pages, it has gone back to Active(Debug) for the Configuration and Active(x64) for the Platform. What's going on there?

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/09/2006 at 03:08, xxxxxxxx wrote:

    Hello Dan,

    are you sure that WIN64 and __C4D_64BIT are deffined in your setings?

    This was the problem for me as I have tried to compile for 64-bit.



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/09/2006 at 06:41, xxxxxxxx wrote:

    Howdy,

    Well, I see WIN64 but I don't see _C4D_64BIT:

    How do I get the _C4D_64BIT in there?

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/09/2006 at 07:25, xxxxxxxx wrote:

    Not sure what do you means, but just add __C4D_64BIT below WIN64. (with 2 lines on begining __C4D_64BIT)
    After this the errors must disapear.

    I use C4D 9.6 SDK!

    Remo



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 28/09/2006 at 07:41, xxxxxxxx wrote:

    Howdy,

    Well, that didn't seem to work.

    The version I have may be 9.0, I don't know for sure because I'm on a 32bit machine trying to do a crossplatform compile and downloaded the 64bit demo quite some time ago when VS 2005 was in beta. I couldn't get it to work back then and when I decided to try again a little while back the beta had expired.

    I just recently upgrade to the VS 2005 Standard, so I can try again. Maybe I need to get rid of that older 64bit demo and download the latest one and start fresh?

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 29/09/2006 at 08:44, xxxxxxxx wrote:

    Howdy,

    OK, I'm a little confused now. I just deleted the older 64bit version 9 from my hard drive, and went to download the latest 64bit. But, I read on Maxon's site that the 64bit was included with the 9.6 update. So I look in my 9.6 update and sure enough there it is!

    So my question now is, how do I set up a 64bit compile for the cinema4dsdk project without screwing up the 32 bit project and the api? (remember, I'm on a 32bit machine)

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 29/09/2006 at 09:19, xxxxxxxx wrote:

    Howdy,

    OK, nevermind. I just made a copy of the folder and put it in another location and named it "Cinema 4D 9.6 64bit", just to keep it separate from the rest.

    And now, I have successfully compiled the cinema4dsdk project for 64bit. Yee-Ha! :o)

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 29/09/2006 at 15:08, xxxxxxxx wrote:

    Dan,

    Great to hear! Now get to work! ;)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 29/09/2006 at 15:38, xxxxxxxx wrote:

    Howdy,

    Hehe, I'm on it. ;o)

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 06:13, xxxxxxxx wrote:

    Howdy Dan,

    can you tell me how this all works on a 32-bit platform? I cannot get it to work. In the configuration manager I don´t even get the x64 platform option. What do I need to get this running?

    Thanks



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 06:22, xxxxxxxx wrote:

    Howdy,

    It seems that when installing MS Visual Studio 2005 Standard on a 32 bit machine, the default installation is 32 bit only. I had to go back and select the option to also install the 64 bit. That was something I missed the first time I installed, and had to reinstall it. :(

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 06:27, xxxxxxxx wrote:

    oh sh**. Thanks, I think I have also chosen 32-bit only back then. Argh..ok, I try a reinstallation. :) Thanks so far!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:08, xxxxxxxx wrote:

    Even on the 64-bit systems you have to be sure to select 64-bit for the install - at least I had this with VS2003. Maybe VS2005 now installs default for the target install system (?).

    Good luck, Samir! :)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:09, xxxxxxxx wrote:

    hmm, when I reinstall, I don´t get an option for 64-Bit in my express installation. Was it the Visual C++ express installation where this happened or is it the platform SDK that you mean?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:12, xxxxxxxx wrote:

    Howdy,

    AH! The "Express" version doesn't have the 64bit option. You need at least the "Standard" version. :(

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:37, xxxxxxxx wrote:

    As Cactus Dan says. :E



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:42, xxxxxxxx wrote:

    no problem robert, I was too lazy in the past to buy the standard version. Now that´s a good reason to finally do so. :-D thx!



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:47, xxxxxxxx wrote:

    Howdy,

    There was an upgrade from MSVC++.net 2003 to MSVC++ 2005 Standard that saved me some money on it. ;)

    You may also have some sort of upgrade option.

    Adios,
    Cactus Dan



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 16/05/2007 at 07:54, xxxxxxxx wrote:

    thanks for the hint. I´ll be checking on this. :)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/06/2007 at 10:53, xxxxxxxx wrote:

    Ok, now got my Standard installed (woosh, 5 fu*** CDs and a Service Pack update of 500 MB. Sigh, I miss the good ol C64 days. :)

    Anyway, it now works to get that compiler to do what it needs. But I get a C4311 error in the TreeView Function GetId()

    The migration docs say:
    "Watch out for type cast warnings. E.g. the line LONG converted_ptr = (LONG)&data; will result in a warning warning C4311: 'type cast' : pointer truncation from 'BaseContainer *' to 'LONG'.. You need to change this code to VLONG converted_ptr = (VLONG)&data;."

    And I am sure that I changed the function in my code correctly. Here it is:

    virtual VLONG GetId(void *root, void *userdata, void *obj)  
    {  
         return (VLONG)obj;  
    }
    

    But I still get the error? The activeobject sdk example uses it in the same way.

    Anybody a clue why it´s not working?

    Thanks!


Log in to reply