XPresso: Add InPort/OutPort of Group Node



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 17/04/2006 at 23:22, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9.102 
    Platform:   Windows  ; Mac  ;  Mac OSX  ; 
    Language(s) :     C++  ;

    ---------
    As the subject says, how do you add a specific InPort or OutPort for a Group XPresso Node? I'm looking for both to be 'Real' ports. I can't find any listing of them for indices available (unless I go the long way as before, I suppose).

    Thanks,

    Robert



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 18/04/2006 at 02:08, xxxxxxxx wrote:

    I don´t see any difference in "normal" nodes and a group node (except for their functionality of course), so doesn´t AddPort work?

    It´s only a guess. I only coded nodes themselves and never played with the interface, so don´t kill my family if it doesn´t work. :-)



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 19/04/2006 at 01:14, xxxxxxxx wrote:

    Although the problem is moot now, it involves what id's are used for these port - are they just enums from 0-n, or are they more unique? These are not resource descriptions so I wasn't certain of how to come by the id's.

    But I've decided to drop the XPresso setup for what I'm doing - too many complications and systemic differences to make it worthwhile.


Log in to reply