Load issues



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 12/01/2006 at 04:07, xxxxxxxx wrote:

    User Information:
    Cinema 4D Version:   9 
    Platform:   Windows  ;   
    Language(s) :     C++  ;

    ---------
    hi all :)
    i have created what i think is the bare minimum code to get a plugin recognised within c4d.  it is a video post plugin and it does show up in render effects tab. however when i load it it always looks for a .str file within /resource/strings_us/decription, i was under the impression if i didnt load a res file or call n e function that required a .str file i would not have to create one. i've tried even creating the relevent folder structure within the plugin path but this doesnt seem to stop it. here is the code, it does compile as i said:

        
        
        
        
        #include <c4d.h>
        
        
        
        
        class greyscale : public VideoPostData
        
        
        
        
        {
        
        
        
        
        public:
        
        
        
        
        static NodeData *Alloc(void) { return gNew greyscale; }
        
        
        
        
        virtual Bool Init(GeListNode *node);
        
        
        
        
        virtual void ExecuteLine(PluginVideoPost *node, PixelPost *PPost);
        
        
        
        
        virtual LONG GetRenderInfo(PluginVideoPost *node) { return VIDEOPOST_REFRESH; }
        
        
        
        
        };
        
        
        
        
        void greyscale::ExecuteLine(PluginVideoPost *node, PixelPost *PPost)
        
        
        
        
        {
        
        
        
        
        }
        
        
        
        
        #define ID_GScale 1000009
        
        
        
        
        Bool greyscale::Init(GeListNode *node)
        
        
        
        
        {
        
        
        
        
        return TRUE;
        
        
        
        
        }
        
        
        
        
         
        
        
        
        
        Bool RegisterGScale(void)
        
        
        
        
        {
        
        
        
        
        return RegisterVideoPostPlugin(ID_GScale,"Grey Scale",0,greyscale::Alloc,"greyscale",0,0);
        
        
        
        
        }
        
        
        
        
        Bool PluginStart(void)
        
        
        
        
        {
        
        
        
        
        RegisterGScale();
        
        
        
        
        return TRUE;
        
        
        
        
        }
        
        
        
        
        void PluginEnd(void)
        
        
        
        
        {
        
        
        
        
        }
        
        
        
        
        Bool PluginMessage(LONG id,void *data)
        
        
        
        
        {
        
        
        
        
        return TRUE;
        
        
        
        
        }
        
        
        
    

    is there n e reason it should need a .str file with this code?



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/01/2006 at 08:30, xxxxxxxx wrote:

    Change this line

      
    return RegisterVideoPostPlugin(ID_GScale,"Grey Scale",0,greyscale::Alloc,"greyscale",0,0);  
    

    to

      
    return RegisterVideoPostPlugin(ID_GScale,"Grey Scale",0,greyscale::Alloc,"",0,0);  
    

    The fifth parameter is trying to use the resource file greayscale.str



  • THE POST BELOW IS MORE THAN 5 YEARS OLD. RELATED SUPPORT INFORMATION MIGHT BE OUTDATED OR DEPRECATED

    On 13/01/2006 at 09:40, xxxxxxxx wrote:

    Ah Gee, i love u man, lol, something so silly.
    now it doesnt give the error and it was so simple to add the 'grey scale' code after that, so my first plugin works, if not somewhat useless :D


Log in to reply